zoukankan      html  css  js  c++  java
  • Hdoj 1008.Elevator 题解

    Problem Description

    The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.
    For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.

    Input

    There are multiple test cases. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100. A test case with N = 0 denotes the end of input. This test case is not to be processed.

    Output

    Print the total time on a single line for each test case.

    Sample Input

    1 2
    3 2 3 1
    0
    

    Sample Output

    17
    41
    

    Author

    ZHENG, Jianqiang

    Source

    ZJCPC2004

    思路

    就是很简单的模拟就好了

    代码

    #include<bits/stdc++.h>
    using namespace std;
    const int MAXN = 100000+10;
    const int UP = 6;
    const int DOWN = 4;
    const int STAY = 5;
    int a[MAXN];
    
    int cal(int a[], int p)
    {
    	int delta = a[p] - a[p-1];
    	int tmp = 0;
    	if(delta > 0)
    		tmp += delta * UP;
    	else
    		tmp += (-delta) * DOWN;
    	return tmp;
    }	//计算电梯相应的移动所需的时间 
    int main()
    {
    	int n;
    	int ans;
    	while(cin>>n&&n!=0)
    	{
    		memset(a,0,sizeof(a));
    		ans = 0;
    		for(int i=1;i<=n;i++)
    		{
    			cin >> a[i];
    			ans += cal(a,i) + STAY;
    		}
    		cout << ans << endl;
    	}
    }
    
  • 相关阅读:
    CENTOS7下安装REDIS
    Linux 查看端口状态netstat
    Centos7启动zookeeper无法连接2181端口
    企业信息化之路---集成
    Linux启动/停止/重启Mysql数据库的方法
    详解线程池
    详细的RocketMQ说明
    2021面试题准备~~~
    Https原理详解
    es 常用DSL
  • 原文地址:https://www.cnblogs.com/MartinLwx/p/9676467.html
Copyright © 2011-2022 走看看