zoukankan      html  css  js  c++  java
  • Hdoj 1160.FatMouse's Speed 题解

    Problem Description

    FatMouse believes that the fatter a mouse is, the faster it runs. To disprove this, you want to take the data on a collection of mice and put as large a subset of this data as possible into a sequence so that the weights are increasing, but the speeds are decreasing.

    Input

    Input contains data for a bunch of mice, one mouse per line, terminated by end of file.
    The data for a particular mouse will consist of a pair of integers: the first representing its size in grams and the second representing its speed in centimeters per second. Both integers are between 1 and 10000. The data in each test case will contain information for at most 1000 mice.
    Two mice may have the same weight, the same speed, or even the same weight and speed.

    Output

    Your program should output a sequence of lines of data; the first line should contain a number n; the remaining n lines should each contain a single positive integer (each one representing a mouse). If these n integers are m[1], m[2],..., m[n] then it must be the case that
    W[m[1]] < W[m[2]] < ... < W[m[n]]
    and
    S[m[1]] > S[m[2]] > ... > S[m[n]]
    In order for the answer to be correct, n should be as large as possible.
    All inequalities are strict: weights must be strictly increasing, and speeds must be strictly decreasing. There may be many correct outputs for a given input, your program only needs to find one.

    Sample Input

    6008 1300
    6000 2100
    500 2000
    1000 4000
    1100 3000
    6000 2000
    8000 1400
    6000 1200
    2000 1900
    

    Sample Output

    4
    4
    5
    9
    7
    

    Source

    Zhejiang University Training Contest 2001


    思路

    按照weight↑,speed↓的顺序来做DP,可以先排序使得按照weight↑的顺序,那么问题就转换为求最长递减子序列问题了,详见注释。

    代码

    #include<bits/stdc++.h>
    using namespace std;
    struct node
    {
    	int w;	//表示weight
    	int s;	//表示speed
    	int id;	//表示序号
    }a[1001];
    int pre[1001];	//记录前驱位置
    int f[1001];
    int ans[1001];	//正序存放位置
    bool cmp(node x, node y)
    {
    	if ( x.w == y.w)
    		return x.s > y.s;
    	return x.w < y.w;
    	return false;
    }//按照weight↑,speed↓的顺序排
    int main()
    {
    	int x,y;
    	int i = 0;
    	while(cin>>x>>y)
    	{
    		a[++i].w = x;
    		a[i].s = y;
    		a[i].id = i;
    		pre[i] = 0; 
    		f[i] = 1;
    	}
    	int len = i;
    	sort(a+1,a+1+len,cmp);
    	
    	int maxlen = -1,maxpos;
    	for(int i=1;i<=len;i++)
    		for(int j=1;j<i;j++)
    		{
    			if(a[i].w > a[j].w && a[i].s < a[j].s && f[i] < f[j] + 1)
    			{
    				f[i] = f[j] + 1;
    				pre[i] = j; 
    				if(f[i] > maxlen)	//求出最大长度顺便记录位置
    				{
    					maxlen = f[i];
    					maxpos = i;
    				}
    			}
    		}
    	int pos = maxpos; 
    	int j = 0;
    	while(pos!=0)
    	{
    		ans[++j] = pos;
    		pos = pre[pos];
    	}//记录正序的位置顺序
    	cout << maxlen << endl;
    	for(int i=j;i>=1;i--)
    		cout << a[ans[i]].id << endl;
    	return 0;
    }
    
  • 相关阅读:
    唤起支付宝的链接地址
    nginx 403 问题解决
    Mac终端生成RAS秘钥对
    nashPay项目遇到的问题
    redis.clients.jedis.exceptions.JedisDataException 解决方案
    Springboot集成Quartz实现分布式任务调度
    Archives版本mysql5.7.23数据库的安装
    Scala语言操作记录
    搭建wordpress个人博客之(2)安装wordpress
    搭建wordpress个人博客之(1)一键安装lnmp[lamp, lnamp]环境
  • 原文地址:https://www.cnblogs.com/MartinLwx/p/9830660.html
Copyright © 2011-2022 走看看