zoukankan      html  css  js  c++  java
  • Hdoj 1374.Knight Moves 题解

    Problem Description

    A friend of you is doing research on the Traveling Knight Problem (TKP) where you are to find the shortest closed tour of knight moves that visits each square of a given set of n squares on a chessboard exactly once. He thinks that the most difficult part of the problem is determining the smallest number of knight moves between two given squares and that, once you have accomplished this, finding the tour would be easy.
    Of course you know that it is vice versa. So you offer him to write a program that solves the "difficult" part.

    Your job is to write a program that takes two squares a and b as input and then determines the number of knight moves on a shortest route from a to b.

    Input

    The input file will contain one or more test cases. Each test case consists of one line containing two squares separated by one space. A square is a string consisting of a letter (a-h) representing the column and a digit (1-8) representing the row on the chessboard.

    Output

    For each test case, print one line saying "To get from xx to yy takes n knight moves.".

    Sample Input

    e2 e4
    a1 b2
    b2 c3
    a1 h8
    a1 h7
    h8 a1
    b1 c3
    f6 f6
    

    Sample Output

    To get from e2 to e4 takes 2 knight moves.
    To get from a1 to b2 takes 4 knight moves.
    To get from b2 to c3 takes 2 knight moves.
    To get from a1 to h8 takes 6 knight moves.
    To get from a1 to h7 takes 5 knight moves.
    To get from h8 to a1 takes 6 knight moves.
    To get from b1 to c3 takes 1 knight moves.
    To get from f6 to f6 takes 0 knight moves.
    

    Source

    University of Ulm Local Contest 1996


    思路

    简单的bfs问题,每次马可以往八个方向跳,只要不出边界,就加到队列后面,直到扩展完所有状态或者到达目标位置就好了

    代码

    #include<bits/stdc++.h>
    using namespace std;
    int x1,y1,x2,y2;
    int x[8]={1,1,2,2,-1,-1,-2,-2};
    int y[8]={2,-2,1,-1,2,-2,1,-1};//马可以跳的八个方向
    struct node
    {
    	int x;
    	int y;
    	int step;
    }st,ed;
    bool vis[10][10];//访问标志
    bool judge(node x)
    {
    	if(x.x<=8&&x.x>=1&&x.y<=8&&x.y>=1)
    		return true;
    	return false;
    }//是否在边界里面的判断
    int getNumber(char c)
    {
    	if(c=='a') return 1;
    	if(c=='b') return 2;
    	if(c=='c') return 3;
    	if(c=='d') return 4;
    	if(c=='e') return 5;
    	if(c=='f') return 6;
    	if(c=='g') return 7;
    	if(c=='h') return 8;
    	
    	if(c=='1') return 1;
    	if(c=='2') return 2;
    	if(c=='3') return 3;
    	if(c=='4') return 4;
    	if(c=='5') return 5;
    	if(c=='6') return 6;
    	if(c=='7') return 7;
    	if(c=='8') return 8;
    }//处理字符串,获得坐标
    int bfs(node st)
    {
    	queue<node> q;
    	memset(vis,false,sizeof(vis));
    	q.push(st);
    	vis[st.x][st.y] = true;
    	if(st.x==ed.x && st.y==ed.y)	return 0;
    	node now,next;
    	while(!q.empty())
    	{
    		now = q.front();
    		q.pop();
    		for(int i=0;i<8;i++)//往八个方向扩展
    		{
    			next.x = now.x + x[i];
    			next.y = now.y + y[i];
    			next.step = now.step + 1;
    			if(next.x==ed.x && next.y==ed.y)
    				return next.step;
    			if(judge(next)&&vis[next.x][next.y]==false)
    			{
    				q.push(next);
    				vis[next.x][next.y]=true;
    			}
    		}
    	}
    }
    		
    int main()
    {
    	string tmp1,tmp2;
    	while(cin>>tmp1>>tmp2)
    	{ 
    		st.x = getNumber(tmp1[1]); st.y = getNumber(tmp1[0]); st.step=0;
    		ed.x = getNumber(tmp2[1]); ed.y = getNumber(tmp2[0]);
    		int ans = bfs(st);
    		cout << "To get from " << tmp1 << " to " << tmp2;
    		cout << " takes " << ans << " knight moves." << endl;
    	}
    	return 0;
    }
    
  • 相关阅读:
    《算法导论》第十章----基本数据结构
    《算法导论》第九章----中位数和顺序统计学
    《算法导论》第八章----线性时间排序(决策树+计数排序+基数排序)
    C++实现快速排序
    C++实现斐波那契第N项非递归与递归实现的时间比较
    C++实现用两个栈实现队列
    C++实现从尾到头打印链表(不改变链表结构)
    C++实现二叉树(建树,前序,中序,后序)递归和非递归实现
    Spark 大数据文本统计
    逻辑回归--参数解释+数据特征不独热编码+训练数据分布可视话
  • 原文地址:https://www.cnblogs.com/MartinLwx/p/9895990.html
Copyright © 2011-2022 走看看