zoukankan      html  css  js  c++  java
  • Lake Counting

    Lake Counting

    Description

    Due to recent rains, water has pooled in various places in Farmer John's field, which is represented by a rectangle of N x M (1 <= N <= 100; 1 <= M <= 100) squares. Each square contains either water ('W') or dry land ('.'). Farmer John would like to figure out how many ponds have formed in his field. A pond is a connected set of squares with water in them, where a square is considered adjacent to all eight of its neighbors. 

    Given a diagram of Farmer John's field, determine how many ponds he has.

    Input

    * Line 1: Two space-separated integers: N and M 

    * Lines 2..N+1: M characters per line representing one row of Farmer John's field. Each character is either 'W' or '.'. The characters do not have spaces between them.

    Output

    * Line 1: The number of ponds in Farmer John's field.

    Sample Input

    10 12
    W........WW.
    .WWW.....WWW
    ....WW...WW.
    .........WW.
    .........W..
    ..W......W..
    .W.W.....WW.
    W.W.W.....W.
    .W.W......W.
    ..W.......W.

    Sample Output

    3

    Hint

    OUTPUT DETAILS: 

    There are three ponds: one in the upper left, one in the lower left,and one along the right side.

    Source

     
     
    ------------------------------------------------------------------------------------------------------------------------------------------
    Source Code:
    #include <iostream>
    
    using namespace std;
    
    int go[][2]={
        {-1,-1},
        {-1,0},
        {-1,1},
        {0,-1},
        {0,1},
        {1,-1},
        {1,0},
        {1,1}
    };
    
    const int arrSize=110;
    char maze[arrSize][arrSize];
    
    void DFS(int x,int y,int n,int m){
        maze[x][y]='.';
        for(int i=0;i<8;++i){
            int newX=x+go[i][0];
            int newY=y+go[i][1];
            if(newX<0||newX>=n)
                continue;
            if(newY<0||newY>=m)
                continue;
            if(maze[newX][newY]=='.')
                continue;
            DFS(newX,newY,n,m);
        }
        return;
    }
    
    int main()
    {
        int N,M;
        int pondsCount;
        while(cin>>N>>M){
            for(int i=0;i<N;++i)
                for(int j=0;j<M;++j)
                    cin>>maze[i][j];
            pondsCount=0;
            for(int i=0;i<N;++i){
                for(int j=0;j<M;++j){
                    if(maze[i][j]=='W'){
                        DFS(i,j,N,M);
                        ++pondsCount;
                    }
                }
            }
            cout<<pondsCount<<endl;
        }
        return 0;
    }
     
  • 相关阅读:
    Lua弱引用table
    Javascript定义类(class)的三种方法
    双检锁技术
    【翻译】ASP.NET缓存管理
    socket python
    mvc项目
    MSBuild
    阅读glibc源码
    MVC3使用Unity实现依赖注入接口与于实现类自动注册
    C# 指针之美
  • 原文地址:https://www.cnblogs.com/Murcielago/p/4217184.html
Copyright © 2011-2022 走看看