zoukankan      html  css  js  c++  java
  • HDU 1102 Constructing Roads

    Constructing Roads

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 14935    Accepted Submission(s): 5691

    Problem Description
    There are N villages, which are numbered from 1 to N, and you should build some roads such that every two villages can connect to each other. We say two village A and B are connected, if and only if there is a road between A and B, or there exists a village C such that there is a road between A and C, and C and B are connected. 

    We know that there are already some roads between some villages and your job is the build some roads such that all the villages are connect and the length of all the roads built is minimum.
     
    Input
    The first line is an integer N (3 <= N <= 100), which is the number of villages. Then come N lines, the i-th of which contains N integers, and the j-th of these N integers is the distance (the distance should be an integer within [1, 1000]) between village i and village j.

    Then there is an integer Q (0 <= Q <= N * (N + 1) / 2). Then come Q lines, each line contains two integers a and b (1 <= a < b <= N), which means the road between village a and village b has been built.
     
    Output
    You should output a line contains an integer, which is the length of all the roads to be built such that all the villages are connected, and this value is minimum. 
     
    Sample Input
    3
    0 990 692
    990 0 179
    692 179 0
    1
    1 2
     
    Sample Output
    179
     
    Source
     
     
    Source Code:
    #include <iostream>
    #include <algorithm>
    
    using namespace std;
    
    struct road{
        int start;
        int end;
        int cost;
    };
    
    int maze[110][110];
    road RoadsArr[100000];
    int Root[110];
    
    bool cmp(road a,road b){
        return a.cost<=b.cost;
    }
    
    void initRoot(int length){
        for(int i=1;i<=length;++i)
            Root[i]=-1;
    }
    
    int findRoot(int x){
        if(Root[x]==-1)
            return x;
        else{
            int tmp=findRoot(Root[x]);
            Root[x]=tmp;
            return tmp;
        }
    }
    
    int Kruskal(int length){
        int answer=0;
        for(int i=0;i<length;++i){
            int Root_a=findRoot(RoadsArr[i].start);
            int Root_b=findRoot(RoadsArr[i].end);
            if(Root_a!=Root_b){
                Root[Root_a]=Root_b;
                answer+=RoadsArr[i].cost;
            }
        }
        return answer;
    }
    
    int main(){
        int N,Q;
        while(cin>>N){
            initRoot(N);
            int index=0;
            for(int i=1;i<=N;++i){
                for(int j=1;j<=N;++j){
                    cin>>maze[i][j];
                    if(i!=j){
                        RoadsArr[index].start=i;
                        RoadsArr[index].end=j;
                        RoadsArr[index].cost=maze[i][j];
                        ++index;
                    }
                }
            }
            sort(RoadsArr,RoadsArr+index,cmp);
            cin>>Q;
            int city_a,city_b;
            for(int i=0;i<Q;++i){
                cin>>city_a>>city_b;
                int Root_a=findRoot(city_a);
                int Root_b=findRoot(city_b);
                if(Root_a!=Root_b)
                    Root[Root_a]=Root_b;
            }
            int answer=Kruskal(index);
            cout<<answer<<endl;
        }
        return 0;
    }
  • 相关阅读:
    SAS学习笔记38 SAS Comments注释语句
    SAS学习笔记37 宏程序中parmbuff选项
    SAS学习笔记36 二分类logistic回归
    SAS学习笔记34 指针控制
    SAS学习笔记33 格式修饰符
    SAS学习笔记31 SAS随机分组方法及实现
    angular的websocket使用
    angularjs 使用ui.router 去掉url中的#号
    angular全局确认框confirm
    angular 请求$http载入画面Loading
  • 原文地址:https://www.cnblogs.com/Murcielago/p/4243527.html
Copyright © 2011-2022 走看看