zoukankan      html  css  js  c++  java
  • HDU 3342 Legal or Not

    Legal or Not

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
    Total Submission(s): 4685    Accepted Submission(s): 2141

    题目描述:

    ACM-DIY is a large QQ group where many excellent acmers get together. It is so harmonious that just like a big family. Every day,many "holy cows" like HH, hh, AC, ZT, lcc, BF, Qinz and so on chat on-line to exchange their ideas. When someone has questions, many warm-hearted cows like Lost will come to help. Then the one being helped will call Lost "master", and Lost will have a nice "prentice". By and by, there are many pairs of "master and prentice". But then problem occurs: there are too many masters and too many prentices, how can we know whether it is legal or not?We all know a master can have many prentices and a prentice may have a lot of masters too, it's legal. Nevertheless,some cows are not so honest, they hold illegal relationship. Take HH and 3xian for instant, HH is 3xian's master and, at the same time, 3xian is HH's master,which is quite illegal! To avoid this,please help us to judge whether their relationship is legal or not. Please note that the "master and prentice" relation is transitive. It means that if A is B's master ans B is C's master, then A is C's master.

    输入:

    The input consists of several test cases. For each case, the first line contains two integers, N (members to be tested) and M (relationships to be tested)(2 <= N, M <= 100). Then M lines follow, each contains a pair of (x, y) which means x is y's master and y is x's prentice. The input is terminated by N = 0.TO MAKE IT SIMPLE, we give every one a number (0, 1, 2,..., N-1). We use their numbers instead of their names.

    输出:

    For each test case, print in one line the judgement of the messy relationship.If it is legal, output "YES", otherwise "NO".

    样例输入:
    3 2
    0 1
    1 2
    2 2
    0 1
    1 0
    0 0
    
    样例输出:
    YES
    NO

    Source Code:

    #include <iostream>
    #include <queue>
    #include <vector>
     
    using namespace std;
     
    vector<int> Relationship[110];
    int inDegree[110];
    queue<int> Q;
     
    void init(int length){
        for(int i=0;i<length;++i){
            inDegree[i]=0;
            Relationship[i].clear();
        }
        while(Q.empty()==false)
            Q.pop();
    }
     
    int main(){
        int n,m;
        while(cin>>n>>m){
            if(n==0&&m==0)
                break;
            init(n);
            int a,b;
            for(int i=0;i<m;++i){
                cin>>a>>b;
                ++inDegree[b];
                Relationship[a].push_back(b);
            }
            for(int i=0;i<n;++i){
                if(inDegree[i]==0){
                    Q.push(i);
                }
            }
            int count=0;
            while(Q.empty()==false){
                int nowP=Q.front();
                for(int i=0;i<Relationship[nowP].size();++i){
                    --inDegree[Relationship[nowP][i]];
                    if(inDegree[Relationship[nowP][i]]==0)
                        Q.push(Relationship[nowP][i]);
                }
                Q.pop();
                ++count;
            }
            if(count==n)
                cout<<"YES"<<endl;
            else
                cout<<"NO"<<endl;
        }
        return 0;
    }
    /**************************************************************
        Problem: 1448
        User: lcyvino
        Language: C++
        Result: Accepted
        Time:10 ms
        Memory:1524 kb
    ****************************************************************/
  • 相关阅读:
    Shiro 集成Spring 使用 redis时 使用redisTemplate替代jedisPool(五)
    shiro 实现 网站登录记住我功能 学习记录(四)
    magento2根据属性id或code来添加options
    微信小程序-注册程序app.js
    微信小程序-目录结构
    如何在最新的PHP 7.1.0上安装和运行最新的Magento 2.1.3
    添加新的php版本到wamp中
    全局使用php
    PHP设计模式之单例模式
    SourceTree使用
  • 原文地址:https://www.cnblogs.com/Murcielago/p/4244260.html
Copyright © 2011-2022 走看看