zoukankan      html  css  js  c++  java
  • Problem E: Automatic Editing

    Problem E: Automatic Editing
    Time Limit: 1 Sec Memory Limit: 128 MB
    Submit: 3 Solved: 3
    [Submit][Status][Web Board]
    Description
    Text-processing tools like awk and sed allow you to automatically perform a sequence of editing operations based on a script. For this problem we consider the specific case in which we want to perform a series of string replacements, within a single line of text, based on a fixed set of rules. Each rule specifies the string to find, and the string to replace it with, as shown below.

    Rule Find Replace-by
    1. ban bab
    2. baba be
    3. ana any
    4. ba b hind the g
    To perform the edits for a given line of text, start with the first rule. Replace the first occurrence of the find string within the text by the replace-by string, then try to perform the same replacement again on the new text. Continue until the find string no longer occurs within the text, and then move on to the next rule. Continue until all the rules have been considered. Note that (1) when searching for a find string, you always start searching at the beginning of the text, (2) once you have finished using a rule (because the find string no longer occurs) you never use that rule again, and (3) case is significant.

    For example, suppose we start with the line

    banana boat
    and apply these rules. The sequence of transformations is shown below, where occurrences of a find string are underlined and replacements are boldfaced. Note that rule 1 was used twice, then rule 2 was used once, then rule 3 was used zero times, and then rule 4 was used once.

    Before After
    banana boat babana boat
    babana boat bababa boat
    bababa boat beba boat
    beba boat behind the goat

    The input contains one or more test cases, followed by a line containing only 0 (zero) that signals the end of the file. Each test case begins with a line containing the number of rules, which will be between 1 and 10. Each rule is specified by a pair of lines, where the first line is the find string and the second line is the replace-by string. Following all the rules is a line containing the text to edit. For each test case, output a line containing the final edited text.

    Both find and replace-by strings will be at most 80 characters long. Find strings will contain at least one character, but replace-by strings may be empty (indicated in the input file by an empty line). During the edit process the text may grow as large as 255 characters, but the final output text will be less than 80 characters long.

    The first test case in the sample input below corresponds to the example shown above.

    Input
    4
    ban
    bab
    baba
    be
    ana
    any
    ba b
    hind the g
    banana boat
    1
    t
    sh
    toe or top
    0

    Output
    behind the goat
    shoe or shop

    Sample Input
    4
    ban
    bab
    baba
    be
    ana
    any
    ba b
    hind the g
    banana boat
    1
    t
    sh
    toe or top
    0
    Sample Output
    behind the goat
    shoe or shop
    my answer:

    #include<iostream>
    #include<cstring>
    #include<string>
     
    using namespace std;
    typedef struct dot{
        string x;
        string y;
    }dot;
    string chati(string f,string h,string d)//f shi wen ben ;h shi x; d shi y;
    {
        int t1=f.size();
        int t2=h.size();
        int t3=d.size();
        int  t=f.find(h);
        while(t!=string::npos){
            string a(f,0,t);
            int tt=t;
            string b(f,t+t2,t1);
            f=a+d+b;
            t=f.find(h);
            t1=f.size() ;
        }
        return f;
    }
    int main()
    {
        int n;
        while(cin>>n)
        {
            getchar();
            if(n==0)
            return 0;
     
            dot a[200];
            char text[100];
            char ww[100];
            char hh[100];
            for(int i=0;i!=n;i++){
                gets(ww);
                string nn(ww);
                gets(hh);
                string mm(hh);
                a[i].x =nn;
                a[i].y =mm;
            }
            gets(text);
            int ff=strlen(text);
            char *p=text;
            string text1(p,ff);
            string str;
            for(int j=0;j!=n;j++){
              str=chati(text1,a[j].x ,a[j].y );
              text1=str;
           }
            cout<<text1<<endl;
        }
        return 0;
    }
  • 相关阅读:
    Maven 那点事儿
    maven pom文件详解
    Maven Missing artifact jar
    JVM调优总结 -Xms -Xmx -Xmn -Xss
    LoadRunner做性能测试 从设计到分析执行
    linux内核参数注释与优化
    tcpdump详解
    [转]Linux服务器上11种网络连接状态 和 TCP三次握手/四次挥手详解
    MSM--Memcached_Session_Manager介绍及使用
    黏性Session和非黏性Session
  • 原文地址:https://www.cnblogs.com/NYNU-ACM/p/4236889.html
Copyright © 2011-2022 走看看