zoukankan      html  css  js  c++  java
  • Rectangles

    Given two rectangles and the coordinates of two points on the diagonals of each rectangle,you have to calculate the area of the intersected part of two rectangles. its sides are parallel to OX and OY .

    Input
    Input The first line of input is 8 positive numbers which indicate the coordinates of four points that must be on each diagonal.The 8 numbers are x1,y1,x2,y2,x3,y3,x4,y4.That means the two points on the first rectangle are(x1,y1),(x2,y2);the other two points on the second rectangle are (x3,y3),(x4,y4).

    Output
    Output For each case output the area of their intersected part in a single line.accurate up to 2 decimal places.

    Sample Input
    1.00 1.00 3.00 3.00 2.00 2.00 4.00 4.00
    5.00 5.00 13.00 13.00 4.00 4.00 12.50 12.50

    Sample Output
    1.00
    56.25

    #include <iostream>
    #include <iomanip>
    using namespace std;
    double cc(double a,double b)
    {
    if(a<b) return a;
    else return b;
    }
    double bb(double a,double b)
    {
    if(a<b) return b;
    else return a;
    }
    int main()
    {
    double x1,x2,x3,x4;
    double y1,y2,y3,y4;
    double a,b,c,d,t;
    while(cin>>x1>>y1>>x2>>y2>>x3>>y3>>x4>>y4)
    {
    if(x1>x2) {t=x1;x1=x2;x2=t;}
    if(y1>y2) {t=y1;y1=y2;y2=t;}
    if(x3>x4) {t=x3;x3=x4;x4=t;}
    if(y3>y4) {t=y3;y3=y4;y4=t;}
    a=bb(x1,x3);
    b=cc(x2,x4);
    c=bb(y1,y3);
    d=cc(y2,y4);
    cout<<setiosflags(ios::fixed)<<setprecision(2);
    cout<<((a>b||c>d)?0:(b-a)*(d-c))<<endl;
    }
    return 0;
    }

  • 相关阅读:
    GetAwaiter和GetResult
    Sql中的小数点和保留位数
    简单工厂类
    c#种GetType()和TypeOf()的区别
    php 内置正则配置邮箱
    通过手机号获取定位
    使用navicat连接mysql 报错:2003-Can't comment to Mysql server on '192.168.X.X'(10038)
    java基础系列(七):内部类的详解
    bootstrap : 响应式导航
    CSS
  • 原文地址:https://www.cnblogs.com/NYNU-ACM/p/4658232.html
Copyright © 2011-2022 走看看