zoukankan      html  css  js  c++  java
  • Crazy Search(POJ1200) 分类: poj 2015-07-25 10:15 6人阅读 评论(0) 收藏

    Description

    Many people like to solve hard puzzles some of which may lead them to madness. One such puzzle could be finding a hidden prime number in a given text. Such number could be the number of different substrings of a given size that exist in the text. As you soon will discover, you really need the help of a computer and a good algorithm to solve such a puzzle.
    Your task is to write a program that given the size, N, of the substring, the number of different characters that may occur in the text, NC, and the text itself, determines the number of different substrings of size N that appear in the text.

    As an example, consider N=3, NC=4 and the text “daababac”. The different substrings of size 3 that can be found in this text are: “daa”; “aab”; “aba”; “bab”; “bac”. Therefore, the answer should be 5.

    Input

    The first line of input consists of two numbers, N and NC, separated by exactly one space. This is followed by the text where the search takes place. You may assume that the maximum number of substrings formed by the possible set of characters does not exceed 16 Millions.

    Output

    The program should output just an integer corresponding to the number of different substrings of size N found in the given text.

    Sample Input
    3 4
    daababac

    Sample Output
    5
    一开始用STL的set来做果断超时了,然后就想用hash做,这道hash有点意思,他给出的NC
    值就是关键字,然后给出的字符串是文本,注意是文本,而不是单单是字母,所以在求每个字符的hash值有点变化。

    #include<stdio.h>
    #include<string.h> 
    #include<iostream> 
    #include<algorithm>
    #include<string> 
    #include<set>
    #include<queue>
    #define maxn 18000000+50
    using namespace std;
    char s[maxn]; 
    bool hash[maxn*10];
    int a[300];
    int n,N;
    int main()
    {
        set<string>S;
        while(cin>>n>>N)
        {
        int count=0;
        memset(hash,0,sizeof(hash));
        memset(a,0,sizeof(a));
        scanf("%s",s);
        int k=strlen(s);
        for(int i=0;i<k;i++)
        {
            if(a[s[i]-' ']==0) 
            { 
            a[s[i]-' ']=1;
            }
        } 
        int num=0;
        for(int i=0;i<=256;i++)
          if(a[i]==1)
          {
           a[i]=num++;
          }
        for(int i=0;i<k-n+1;i++)
              {
                long long h=0;
                for(int j=i;j<i+n;j++)
                h=h*N+a[s[j]-' '];
                if(!hash[h])
                {
                count++;
                hash[h]=1;
               }
               }
               cout<<count<<endl;
         }
        return 0;
    }
    

    版权声明:本文为博主原创文章,未经博主允许不得转载。

  • 相关阅读:
    SSH出错---The method getRealPath(String) from the type ServletRequest is deprecated request.getRealPath("")
    Struts2学习9--文件下载
    Struts2学习9--中文文件下载的问题
    Struts2学习8--文件上传(多个文件上传)
    把字符串数据存到字典当中
    新建可变数组,来接收原来不可变的数组NSArry
    oc将字典中内容添加到数组中
    输出字典中的key和 value
    NSArray基础数组的排序
    在oc中把原本字符串123-456-789-000里面的-去掉然后输出最简单方法
  • 原文地址:https://www.cnblogs.com/NaCl/p/4700585.html
Copyright © 2011-2022 走看看