zoukankan      html  css  js  c++  java
  • 【POJ】2796:Feel Good【单调栈】

    Feel Good
    Time Limit: 3000MS Memory Limit: 65536K
    Total Submissions: 18449 Accepted: 5125
    Case Time Limit: 1000MS Special Judge
    Description

    Bill is developing a new mathematical theory for human emotions. His recent investigations are dedicated to studying how good or bad days influent people's memories about some period of life.

    A new idea Bill has recently developed assigns a non-negative integer value to each day of human life.

    Bill calls this value the emotional value of the day. The greater the emotional value is, the better the daywas. Bill suggests that the value of some period of human life is proportional to the sum of the emotional values of the days in the given period, multiplied by the smallest emotional value of the day in it. This schema reflects that good on average period can be greatly spoiled by one very bad day.

    Now Bill is planning to investigate his own life and find the period of his life that had the greatest value. Help him to do so.
    Input

    The first line of the input contains n - the number of days of Bill's life he is planning to investigate(1 <= n <= 100 000). The rest of the file contains n integer numbers a1, a2, ... an ranging from 0 to 106 - the emotional values of the days. Numbers are separated by spaces and/or line breaks.
    Output

    Print the greatest value of some period of Bill's life in the first line. And on the second line print two numbers l and r such that the period from l-th to r-th day of Bill's life(inclusive) has the greatest possible value. If there are multiple periods with the greatest possible value,then print any one of them.

    Sample Input

    6
    3 1 6 4 5 2
    

    Sample Output

    60
    3 5
    

    Solution

    题意:找一个区间,使这个区间最小值乘上这个区间的和最大。

    用单调栈维护递增,找出以每个i为最小值的最远的左右端点即可。

    每次弹栈就更新被弹元素的右端点,入栈时更新入栈元素的左端点即可。

    (为什么不把题说清楚有多组数据还有spj太垃圾了吧必须要区间最小!!!!)

    (真的受不了了为什么poj那么卡aaaaa!!!浪费了我好多好多时间!!!!!!!!【粉转黑!!)

    #include<cstdio>
    #include<iostream>
    #include<cstring>
    #include<algorithm>
    #define LL long long
    using namespace std;
    LL a[100005], pre[100005];
    int stk[100005], R[100005], L[100005], n;
    int main() {
        while(~scanf("%d", &n)) {
            int top = 0;
            memset(pre, 0, sizeof(pre));
            memset(L, 0, sizeof(L));
            memset(R, 0, sizeof(R));
            for(int i = 1; i <= n; i ++) {
                scanf("%I64d", &a[i]);
                pre[i] = pre[i - 1] + a[i];
                while(a[i] < a[stk[top]] && top) {
                    R[stk[top --]] = i - 1;
                }
                L[i] = stk[top] + 1;
                stk[++ top] = i;
            }
            while(top) {
                R[stk[top --]] = n;
            }
            LL ans = 0; int l, r;
            for(int i = 1; i <= n; i ++) {
                LL tmp = (pre[R[i]] - pre[L[i] - 1]) * a[i];
                if(tmp > ans) {
                    ans = tmp;
                    l = L[i], r = R[i];
                }
                if(tmp == ans) {
                    if(R[i] - L[i] + 1 < r - l + 1) {
                        l = L[i], r = R[i];
                    }
                }
            }
            printf("%I64d
    %d %d
    ", ans, l, r);
        }
        
        return 0;
    }
    
  • 相关阅读:
    Ansible跳板机自动部署
    nginx展示文件目录
    【转】消息钩子注册浅析
    windows临界区
    windbg定位死锁
    Windows工作集内存
    我的spring boot,杨帆、起航!
    CursorFileManager对cursor文件的读写
    eclipse执行maven install命令时跳过test
    bASE--Risk
  • 原文地址:https://www.cnblogs.com/NoTimepleasssse/p/9826250.html
Copyright © 2011-2022 走看看