zoukankan      html  css  js  c++  java
  • 抽屉问题 Find a multiple POJ

    The input contains N natural (i.e. positive integer) numbers ( N <= 10000 ). Each of that numbers is not greater than 15000. This numbers are not necessarily different (so it may happen that two or more of them will be equal). Your task is to choose a few of given numbers ( 1 <= few <= N ) so that the sum of chosen numbers is multiple for N (i.e. N * k = (sum of chosen numbers) for some natural number k).

    Input

    The first line of the input contains the single number N. Each of next N lines contains one number from the given set.

    Output

    In case your program decides that the target set of numbers can not be found it should print to the output the single number 0. Otherwise it should print the number of the chosen numbers in the first line followed by the chosen numbers themselves (on a separate line each) in arbitrary order. 

    If there are more than one set of numbers with required properties you should print to the output only one (preferably your favorite) of them.

    Sample Input

    5
    1
    2
    3
    4
    1
    

    Sample Output

    2
    2
    3

    思路: 打表可知一定有一段区间的解
    前缀和一下 发现 满足的条件为 s[i]%n==s[j]%n (*)
    又因为 0到 n 有 n+1个数
    但是前缀和的答案为 0 到 n-1 有 n 个数
    所以一定有两个前缀和满足(*)的条件
    暴力即可
    code:
    //
    #include<iostream>
    using namespace std;
    int n;
    #define maxnn 20000
    int sum[maxnn];
    int a[maxnn];
    int main()
    {
        cin>>n;
        for(int i=1;i<=n;i++)
        {
            cin>>a[i];
            sum[i]=(sum[i-1]+a[i])%n;
        }
        for(int i=1;i<=n;i++)
            for(int j=i;j<=n;j++)
            {
                if(sum[i-1]==sum[j])
                {
                    cout<<j-i+1<<endl;
                    for(int k=i;k<=j;k++)
                    {
                        cout<<a[k]<<endl;
                    }return 0;
                }
            }
        
        
    }


    刀剑映出了战士的心。而我的心,漆黑且残破
  • 相关阅读:
    Vs2010 编辑器自动提示crash的解决办法
    史丹佛毕业25年 我最有钱的同学是...zz
    Workerman3 创建wss服务 利用apache代理wss
    vue面试装X知识汇总
    接:this is incompatible with sql_mode=only_full_group_by
    vue2 nuxtjs 使用与安装
    linux 升级安装最新版本的composer2.0
    Ubuntu20.04LTS 添加环境变量
    this is incompatible with sql_mode=only_full_group_by
    CC2420与IEEE802.15.4关系
  • 原文地址:https://www.cnblogs.com/OIEREDSION/p/11308385.html
Copyright © 2011-2022 走看看