zoukankan      html  css  js  c++  java
  • 抽屉问题 Find a multiple POJ

    The input contains N natural (i.e. positive integer) numbers ( N <= 10000 ). Each of that numbers is not greater than 15000. This numbers are not necessarily different (so it may happen that two or more of them will be equal). Your task is to choose a few of given numbers ( 1 <= few <= N ) so that the sum of chosen numbers is multiple for N (i.e. N * k = (sum of chosen numbers) for some natural number k).

    Input

    The first line of the input contains the single number N. Each of next N lines contains one number from the given set.

    Output

    In case your program decides that the target set of numbers can not be found it should print to the output the single number 0. Otherwise it should print the number of the chosen numbers in the first line followed by the chosen numbers themselves (on a separate line each) in arbitrary order. 

    If there are more than one set of numbers with required properties you should print to the output only one (preferably your favorite) of them.

    Sample Input

    5
    1
    2
    3
    4
    1
    

    Sample Output

    2
    2
    3

    思路: 打表可知一定有一段区间的解
    前缀和一下 发现 满足的条件为 s[i]%n==s[j]%n (*)
    又因为 0到 n 有 n+1个数
    但是前缀和的答案为 0 到 n-1 有 n 个数
    所以一定有两个前缀和满足(*)的条件
    暴力即可
    code:
    //
    #include<iostream>
    using namespace std;
    int n;
    #define maxnn 20000
    int sum[maxnn];
    int a[maxnn];
    int main()
    {
        cin>>n;
        for(int i=1;i<=n;i++)
        {
            cin>>a[i];
            sum[i]=(sum[i-1]+a[i])%n;
        }
        for(int i=1;i<=n;i++)
            for(int j=i;j<=n;j++)
            {
                if(sum[i-1]==sum[j])
                {
                    cout<<j-i+1<<endl;
                    for(int k=i;k<=j;k++)
                    {
                        cout<<a[k]<<endl;
                    }return 0;
                }
            }
        
        
    }


    刀剑映出了战士的心。而我的心,漆黑且残破
  • 相关阅读:
    【转】分治法求最大值最小值
    JPA基本实体映射学习
    android权限
    Servlet实现基本文件上传
    Flask项目部署(nginx+supervisor+uwsgi)
    DevExpress学习笔记(三)XtraGrid
    DevExpress学习笔记(五)-以拖拽的方式构建树(TreeList)
    使用ICE建立C++与C#的通讯
    带有Wallet的impdp导入过程
    调用ODAC报BadImageFormatException异常的解决方法
  • 原文地址:https://www.cnblogs.com/OIEREDSION/p/11308385.html
Copyright © 2011-2022 走看看