zoukankan      html  css  js  c++  java
  • 九度OJ1184二叉树

    题目描述:

    编一个程序,读入用户输入的一串先序遍历字符串,根据此字符串建立一个二叉树(以指针方式存储)。
    例如如下的先序遍历字符串:
    ABC##DE#G##F###
    其中“#”表示的是空格,空格字符代表空树。建立起此二叉树以后,再对二叉树进行中序遍历,输出遍历结果。

    输入:

    输入包括1行字符串,长度不超过100。

    输出:

    可能有多组测试数据,对于每组数据,
    输出将输入字符串建立二叉树后中序遍历的序列,每个字符后面都有一个空格。
    每个输出结果占一行。

    样例输入:
    abc##de#g##f###
    样例输出:
    c b e g d f a 
    #include<stdio.h>
    #include<stdlib.h>
    char cache[101];
    typedef struct Node
    {
        char data;
        struct Node *lchild,*rchild;
    }tree;
    tree * root;
    
    int cnt;
    tree * Build_tree(){
        tree * root;
        if(cache[cnt++]=='#') root=NULL;
        else{
            root=(tree *)malloc(sizeof(tree));
            root->data = cache[cnt-1];
            root->lchild = Build_tree();
            root->rchild = Build_tree();
        }
        return root;
    }
    void in_order(tree *root){
        if(root!=NULL){
            in_order(root->lchild);
            printf("%c ",root->data);
            in_order(root->rchild);
        }
    }
    int main(){
        while(~scanf("%s",cache)){
            cnt=0;
            root=Build_tree();
            in_order(root);
        }
    }
  • 相关阅读:
    solr6.0学习
    shell定时任务
    LINUX调优
    OnlineJudge大集合
    [GRYZ2015]快排练习
    [洛谷1240]诸侯安置
    [NOI导刊2011]影像之结构化特征
    手把手教你写对拍程序(PASCAL)
    [NOIP2013]转圈游戏
    [GRYZ2015]阿Q的停车场
  • 原文地址:https://www.cnblogs.com/OMG-By/p/5364981.html
Copyright © 2011-2022 走看看