zoukankan      html  css  js  c++  java
  • HDU-1018 BigNumber

    Big Number

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 38450    Accepted Submission(s): 18633


    Problem Description
    In many applications very large integers numbers are required. Some of these applications are using keys for secure transmission of data, encryption, etc. In this problem you are given a number, you have to determine the number of digits in the factorial of the number.
     

    Input
    Input consists of several lines of integer numbers. The first line contains an integer n, which is the number of cases to be tested, followed by n lines, one integer 1 ≤ n ≤ 107 on each line.
     

    Output
    The output contains the number of digits in the factorial of the integers appearing in the input.
     

    Sample Input
    2 10 20
     

    Sample Output
    7 19
     

    Source
     

    Recommend
    JGShining   |   We have carefully selected several similar problems for you:  1017 1071 1019 1060 1089 

    分析:
    如何知道一个数有多少位呢?这还不简单,从左到右数一数,24678,嘿嘿嘿,其实可以这样,假设一个数N,它的位数是x,则10^(x-1)<=N<10^x,两边取对数,x - 1<= log10(n),x = (int)log10(n)+1; N!=1*2*3*...*(N-1)*N; N! 的位数也就是(1*2*3...*(N-1)*N)的位数,也就是log10(1*2*3*...*(N-1)*(N))+1,根据对数的运算性质,log(a*b) = log(a) + log(b),log10(N!) = log10(1)+log10(2)+log10(3)+....+log10(N-1)+log10(N);

    代码:
    import java.util.Scanner;
    public class Main{
        public static void main(String argc[]){
            Scanner cin = new Scanner(System.in);
            int T = cin.nextInt();
            while(T-->0){
                int n = cin.nextInt();
                double total = 0;
                for(int i=1;i<=n;i++) total+=Math.log10(i);
                System.out.println((int)total+1);
            }
        }
    }

  • 相关阅读:
    线段树(updata+query)
    铁轨(栈)
    困难的串(搜索)
    素数环(简单搜索)
    编码
    opencv + numpy for python
    PIL参考手册
    八数码问题
    三维地图(BFS)
    梯田(dfs)
  • 原文地址:https://www.cnblogs.com/Pretty9/p/7347682.html
Copyright © 2011-2022 走看看