zoukankan      html  css  js  c++  java
  • 搜索专题: HDU1027Ignatius and the Princess II

    Ignatius and the Princess II

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 8497    Accepted Submission(s): 5002


    Problem Description
    Now our hero finds the door to the BEelzebub feng5166. He opens the door and finds feng5166 is about to kill our pretty Princess. But now the BEelzebub has to beat our hero first. feng5166 says, "I have three question for you, if you can work them out, I will release the Princess, or you will be my dinner, too." Ignatius says confidently, "OK, at last, I will save the Princess."

    "Now I will show you the first problem." feng5166 says, "Given a sequence of number 1 to N, we define that 1,2,3...N-1,N is the smallest sequence among all the sequence which can be composed with number 1 to N(each number can be and should be use only once in this problem). So it's easy to see the second smallest sequence is 1,2,3...N,N-1. Now I will give you two numbers, N and M. You should tell me the Mth smallest sequence which is composed with number 1 to N. It's easy, isn't is? Hahahahaha......"
    Can you help Ignatius to solve this problem?
     

    Input
    The input contains several test cases. Each test case consists of two numbers, N and M(1<=N<=1000, 1<=M<=10000). You may assume that there is always a sequence satisfied the BEelzebub's demand. The input is terminated by the end of file.
     

    Output
    For each test case, you only have to output the sequence satisfied the BEelzebub's demand. When output a sequence, you should print a space between two numbers, but do not output any spaces after the last number.
     

    Sample Input
    6 4 11 8
     

    Sample Output
    1 2 3 5 6 4 1 2 3 4 5 6 7 9 8 11 10
     

    Author
    Ignatius.L
    #include<iostream>
    #include<cstring>
    #include<cstdio>
    
    using namespace std;
    const int N = 1000 + 5;
    bool visit[N];
    int a[N],n,m,cnt;
    
    void DFS(int cur){
        if(cnt>=m) return;
        if(cur > n ){
            cnt++;
            if(cnt == m)
                for(int i=1;i<=n;i++)
                    printf("%d%c",a[i],i<n?' ':'
    ');
            return;
        }
        for(int i=1;i<=n;i++){
            if(!visit[i]){
                visit[i] = true;
                a[cur] = i;
                DFS(cur + 1);
                visit[i] = false;
            }
        }
    }
    int main(){
        while(scanf("%d %d",&n,&m)==2){
            cnt = 0;
            DFS(1);
        }
    }
    

     
  • 相关阅读:
    记一次线上OOM问题分析与解决
    理解JAVA内存模型
    SpringBoot+Shiro+JPA+LayUI的后台管理系统
    学会使用BeanUtils,提高你的开发效率
    一篇文章教你快速上手接口管理工具swagger
    js 多维数组转一维数组(根据字段展示)
    记一次阿里云服务器中部署egg遇到的问题 (docker vim)
    react 封装tab组件
    js 添加 好玩的注释
    js 下载文件流
  • 原文地址:https://www.cnblogs.com/Pretty9/p/7347707.html
Copyright © 2011-2022 走看看