zoukankan      html  css  js  c++  java
  • 解码锁

    Problem B: B

    Time Limit: 1 Sec  Memory Limit: 128 MB
    Submit: 96  Solved: 43
    [Submit][Status][Web Board]

    Description

    Now that you're back to school for another term, you need to remember how to work the combination lock on your locker. A common design is that of the Master Brand, shown at right. The lock has a dial with 40 calibration marks numbered 0 to 39. A combination consists of 3 of these numbers; for example: 15-25-8. To open the lock, the following steps are taken:
    • turn the dial clockwise 2 full turns
    • stop at the first number of the combination
    • turn the dial counter-clockwise 1 full turn
    • continue turning counter-clockwise until the 2nd number is reached
    • turn the dial clockwise again until the 3rd number is reached
    • pull the shank and the lock will open.

    Given the initial position of the dial and the combination for the lock, how many degrees is the dial rotated in total (clockwise plus counter-clockwise) in opening the lock?

    Input

    Input consists of several test cases. For each case there is a line of input containing 4 numbers between 0 and 39. The first number is the position of the dial. The next three numbers are the combination. Consecutive numbers in the combination will be distinct. A line containing 0 0 0 0 follows the last case.

    Output

    For each case, print a line with a single integer: the number of degrees that the dial must be turned to open the lock.

    Sample Input

    0 30 0 30
    5 35 5 35
    0 20 0 20
    7 27 7 27
    0 10 0 10
    9 19 9 19
    0 0 0 0

    Sample Output

    1350
    1350
    1620
    1620
    1890
    1890
    对应的程序如下:
     
    #include"stdio.h"
    #include"stdlib.h"
    int main()
    {
       int a,b,c,d,sum;
       while(1)
       {
            scanf("%d%d%d%d",&a,&b,&c,&d);
            if((!a)&&(!b)&&(!c)&&(!d))
              break;
            else
             sum=720+360;
             sum+=((40-b+a)%40*9);
             sum+=((40-b+c)%40*9);
             sum+=((40-d+c)%40*9);
             printf("%d\n",sum);
       }
       // system("pause");
       return 0; 
           
    }
  • 相关阅读:
    跳槽“六要”你懂吗?[转载]
    基于RFID 技术的仓储物流入库流程设计[转载]
    RFID:物流时代的新宠儿[转载]
    WEB界面设计五种特征[转]
    全国物流快递查询网址大全
    职员想跳槽,公司应检讨[转]
    商品条码管理办法 (2005)
    让总裁夜不成眠三件事[转]
    Google地图的配色问题(以及MapBar和51ditu)
    薪酬公开还是保密[转]
  • 原文地址:https://www.cnblogs.com/QQbai/p/2122243.html
Copyright © 2011-2022 走看看