zoukankan      html  css  js  c++  java
  • hdu 数值转换

    Skew Binary
    Time Limit: 3000MS Memory Limit: Unknown 64bit IO Format: %lld & %llu

    [Submit]   [Go Back]   [Status]

    Description

      Skew Binary 

    When a number is expressed in decimal, the k-th digit represents a multiple of 10k. (Digits are numbered from right to left, where the least significant digit is number 0.) For example, 

    \begin{displaymath}81307_{10} = 8 \times 10^4 + 1 \times 10^3 + 3 \times 10^2 + ...
...mes 10^1 +
7 \times 10 0 = 80000 + 1000 + 300 + 0 + 7
= 81307.
\end{displaymath}

    When a number is expressed in binary, the k-th digit represents a multiple of 2k. For example, 

    \begin{displaymath}10011_2 = 1 \times 2^4 + 0 \times 2^3 + 0 \times 2^2 + 1 \times 2^1 +
1 \times 2^0 = 16 + 0 + 0 + 2 + 1 = 19.
\end{displaymath}

    In skew binary, the k-th digit represents a multiple of 2k+1 - 1. The only possible digits are 0 and 1, except that the least-significant nonzero digit can be a 2. For example, 

    \begin{displaymath}10120_{skew} = 1 \times (2^5 - 1) + 0 \times (2^4-1) + 1 \tim...
...2 \times (2^2-1) + 0 \times (2^1-1)
= 31 + 0 + 7 + 6 + 0 = 44.
\end{displaymath}

    The first 10 numbers in skew binary are 0, 1, 2, 10, 11, 12, 20, 100, 101, and 102. (Skew binary is useful in some applications because it is possible to add 1 with at most one carry. However, this has nothing to do with the current problem.)

    Input 

    The input file contains one or more lines, each of which contains an integer n. If n = 0 it signals the end of the input, and otherwise n is a nonnegative integer in skew binary.

    Output 

    For each number, output the decimal equivalent. The decimal value of n will be at most 231 - 1 = 2147483647.

    Sample Input 

    10120
    200000000000000000000000000000
    10
    1000000000000000000000000000000
    11
    100
    11111000001110000101101102000
    0
    

    Sample Output 

    44
    2147483646
    3
    2147483647
    4
    7
    1041110737
    
    #include<stdio.h>
    #include<string.h>
    #include<stdlib.h>
    int main()
    {
        char in[32]={0};
        while(scanf("%s",in),strcmp(in,"0")!=0)
        {
            long long sum=0,s;
            int len=strlen(in);
            for(int i=0;i<len;i++)
            {
                s=1;
                for(int j=1;j<=len-i;j++)
                {
                    s*=2;        
                }
                sum+=(s-1)*(in[i]-'0');
            }
            printf("%lld\n",sum);
        }    
        //system("pause");
        return 0;
    }
     

  • 相关阅读:
    我的黑客偶像
    2020-2021-1学期 学号20201222 《信息安全专业导论》第5周学习总结
    XOR加密
    pep/9
    我的黑客偶像
    学年2020-2021,1 学号:20201222《信息安全专业导论》第4周学习总结”
    IEEE754浮点数转换
    师生关系
    罗马数字转阿拉伯数字
    第三周总结
  • 原文地址:https://www.cnblogs.com/QQbai/p/2169167.html
Copyright © 2011-2022 走看看