zoukankan      html  css  js  c++  java
  • 模拟 [bzoj 4582] Diamond Collector

    这道是权限,所以我粘个题面

    Time Limit: 10 Sec Memory Limit: 128 MB
    Submit: 198 Solved: 134
    [Submit][Status][Discuss]
    Description
    Bessie the cow, always a fan of shiny objects, has taken up a hobby of mining diamonds in her spare
    time! She has collected N diamonds (N≤50,000) of varying sizes, and she wants to arrange some of th
    em in a pair of display cases in the barn.Since Bessie wants the diamonds in each of the two cases t
    o be relatively similar in size, she decides that she will not include two diamonds in the same case
    if their sizes differ by more than K (two diamonds can be displayed together in the same case if th
    eir sizes differ by exactly K). Given K, please help Bessie determine the maximum number of diamonds
    she can display in both cases together.
    给定长度为N的数列a,要求选出两个互不相交的子序列(可以不连续),满足同一个子序列中任意两个元素差的绝
    对值不超过K。最大化两个子序列长度的和并输出这个值。1 ≤ N ≤ 50000, 1 ≤ a_i ≤ 10 ^ 9, 0 ≤ K ≤ 10^ 9
    Input
    The first line of the input file contains N and K (0≤K≤1,000,000,000). The next NN lines each cont
    ain an integer giving the size of one of the diamonds. All sizes will be positive and will not excee
    d 1,000,000,000
    Output
    Output a single positive integer, telling the maximum number of diamonds that Bessie can showcase in
    total in both the cases.
    Sample Input
    7 3
    10
    5
    1
    12
    9
    5
    14
    Sample Output
    5
    HINT

    我们可以搞出对于每个点,他左边的最大长度,他右边的最大长度。
    只要枚举左端点,找出最右面的端点,不断更新,反正乱搞出向左向右的最大值,之后重新枚举每个区间,找他左或右的最大值,更新答案。
    真没自己想出来,有些貌似数据结构的题,其实会很简单。。

    #pragma GCC optimize("O3")
    #include<cstdio>
    #include<cstdlib>
    #include<cstring>
    #include<iostream>
    #include<algorithm>
    #define N 50005
    using namespace std;
    int n,k,a[N],L[N],R[N];
    int main()
    {   
        scanf("%d%d",&n,&k);
        for(int i=1;i<=n;i++)scanf("%d",&a[i]);
        sort(a+1,a+n+1);
        if(a[n]-a[1]<=2*k){cout<<n;return 0;}
        for(int l=1,r=1;l<=n;l++)
        {
            while(r<=n&&a[r]-a[l]<=k){R[l]=max(R[l],r-l+1);r++;}
            r--;R[l]=max(R[l],r-l+1);L[r]=r-l+1;
        }
        for(int i=1;i<=n;i++)if(L[i-1]>L[i])L[i]=L[i-1];
        for(int i=n;i>=1;i--)if(R[i+1]>R[i])R[i]=R[i+1];
        int ans=0;
        for(int l=1,r=1;l<=n;l++)
        {
            while(r<=n&&a[r]-a[l]<=k)r++;
            r--;ans=max(ans,r-l+1+max(L[l-1],R[r+1]));
        }
        cout<<ans;
    }
  • 相关阅读:
    P3133 [USACO16JAN]无线电联系Radio Contact
    P2196 挖地雷
    P2434 [SDOI2005]区间
    P2820 局域网
    P2904 [USACO08MAR]跨河River Crossing
    P1586 四方定理
    P2983 [USACO10FEB]购买巧克力Chocolate Buying
    P2049 魔术棋子
    kali-linux破解密码运行脚本并隐藏进程
    kali安装使用
  • 原文地址:https://www.cnblogs.com/QTY2001/p/7632663.html
Copyright © 2011-2022 走看看