zoukankan      html  css  js  c++  java
  • 【题解】Qin Shi Huang's National Road System HDU 4081 ⭐⭐⭐⭐ 【次小生成树】

    During the Warring States Period of ancient China(476 BC to 221 BC), there were seven kingdoms in China ---- they were Qi, Chu, Yan, Han, Zhao, Wei and Qin. Ying Zheng was the king of the kingdom Qin. Through 9 years of wars, he finally conquered all six other kingdoms and became the first emperor of a unified China in 221 BC. That was Qin dynasty ---- the first imperial dynasty of China(not to be confused with the Qing Dynasty, the last dynasty of China). So Ying Zheng named himself "Qin Shi Huang" because "Shi Huang" means "the first emperor" in Chinese.
    始皇帝
    Qin Shi Huang undertook gigantic projects, including the first version of the Great Wall of China, the now famous city-sized mausoleum guarded by a life-sized Terracotta Army, and a massive national road system. There is a story about the road system:
    There were n cities in China and Qin Shi Huang wanted them all be connected by n-1 roads, in order that he could go to every city from the capital city Xianyang.
    Although Qin Shi Huang was a tyrant, he wanted the total length of all roads to be minimum,so that the road system may not cost too many people's life. A daoshi (some kind of monk) named Xu Fu told Qin Shi Huang that he could build a road by magic and that magic road would cost no money and no labor. But Xu Fu could only build ONE magic road for Qin Shi Huang. So Qin Shi Huang had to decide where to build the magic road. Qin Shi Huang wanted the total length of all none magic roads to be as small as possible, but Xu Fu wanted the magic road to benefit as many people as possible ---- So Qin Shi Huang decided that the value of A/B (the ratio of A to B) must be the maximum, which A is the total population of the two cites connected by the magic road, and B is the total length of none magic roads.
    Would you help Qin Shi Huang?
    A city can be considered as a point, and a road can be considered as a line segment connecting two points.


    Input

    The first line contains an integer t meaning that there are t test cases(t <= 10).
    For each test case:
    The first line is an integer n meaning that there are n cities(2 < n <= 1000).
    Then n lines follow. Each line contains three integers X, Y and P ( 0 <= X, Y <= 1000, 0 < P < 100000). (X, Y) is the coordinate of a city and P is the population of that city.
    It is guaranteed that each city has a distinct location.

    Output

    For each test case, print a line indicating the above mentioned maximum ratio A/B. The result should be rounded to 2 digits after decimal point.

    Sample Input

    2
    4
    1 1 20
    1 2 30
    200 2 80
    200 1 100
    3
    1 1 20
    1 2 30
    2 2 40
    

    Sample Output

    65.00
    70.00
    

    题意:

    给出N个点的坐标以及每个点的人口, 要求将这N个点通过N-1条边连接起来, 权值为两点直接距离, B为距离和, 同时可以选中一条边, 使得该边权值变为0, A为该边两点人口数量. 求A/B的最大值

    题解:

    既然要求A/B的最大值, 就一定要A最大, B最小, 所以B需要求一下MST, A的话我们直接枚举每条边就好了, 如果该边已经在MST中,$$ ans = max(ans, A/(B-w[i][j]));$$ 否则$$ans = max(ans, A/(B-maxD[i][j]));$$

    可以看到, 虽然这里没有直接使用次小生成树, 但是完全用到了次小生成树求出的几个数组, 这也是前面为何没有直接求出次小生成树的原因, 因为大部分的题目必然不是裸题, 所以更要仔细理解次小生成树的思想

    #include<bits/stdc++.h>
    using namespace std;
    #define ms(x, n) memset(x,n,sizeof(x));
    typedef  long long LL;
    const int inf = 1 << 30;
    const LL maxn = 1010;
    
    int N;
    double w[maxn][maxn];
    struct node {
        int x, y;
        int p;
        node(int xx, int yy, int pp) { x = xx, y = yy, p = pp; }
        node() {}
    } vs[maxn];
    double getDis(int x1, int y1, int x2, int y2) {
        return sqrt((double)(x1 - x2) * (x1 - x2) + (y1 - y2) * (y1 - y2));
    }
    double d[maxn];
    bool used[maxn];
    double maxD[maxn][maxn];   //MST中从i->j的最大权值
    int pre[maxn];          //某一点父节点
    bool mst[maxn][maxn];   //该点是否已经在MST中
    typedef pair<int, int> P;
    double Prim(int s) {
        fill(d, d + maxn, inf);
        fill(pre, pre + maxn, s);
        ms(maxD, 0); ms(used, 0); ms(mst, 0);
        priority_queue<P, vector<P>, greater<P> > q;
        q.push(P(d[s] = 0, s));
        double res = 0;
        while (!q.empty()) {
            P cur = q.top();
            q.pop();
            int u = cur.second;
            if (used[u])
                continue;
            used[u] = true, res += d[u];
            mst[u][pre[u]] = mst[pre[u]][u] = true; //加入到MST中
            for (int v = 1; v <= N; ++v) {
                if (used[v] && w[u][v] < inf)        //只更新MST中的
                    maxD[u][v] = maxD[v][u] = max(maxD[pre[u]][v], d[u]);
                if (w[u][v] < d[v]) {
                    d[v] = w[u][v];
                    pre[v] = u;                     //更新父节点
                    q.push(P(d[v], v));
                }
            }
        }
        return res;
    }
    int main() {
        //freopen("in.txt", "r", stdin);
        int T, a, b, c;
        scanf("%d", &T);
        while (T--) {
            ms(vs, 0); fill(w[0], w[0] + maxn * maxn, inf);
            scanf("%d", &N);
            for (int i = 1; i <= N; ++i) {
                scanf("%d%d%d", &a, &b, &c);
                vs[i] = node(a, b, c);
            }
            for (int i = 1; i < N; ++i)
                for (int j = i + 1; j <= N; ++j)
                    w[i][j] = w[j][i] = getDis(vs[i].x, vs[i].y, vs[j].x, vs[j].y);
    
            //枚举删边, 找出最大值
            double B = Prim(1), A, ans = -1;
            for (int i = 1; i < N; ++i)
                for (int j = i + 1; j <= N; ++j) {
                    A = vs[i].p + vs[j].p;
                    //这条边未在MST中使用, 尝试加边并删去生成环中的最长边, 已使用则直接变0
                    if (mst[i][j]) {
                        ans = max(ans, A / (B - w[i][j]));
                    }
                    else {
                        ans = max(ans, A / (B - maxD[i][j]));
                    }
                }
            printf("%.2lf\n", ans);
        }
    
        return 0;
    }
    
  • 相关阅读:
    dedecmsV5.7和discuz!X3.4整合之后免激活登陆
    dedecms织梦文章微信分享带缩略图与简介
    关于PHP的mkdir函数
    关于discuz的fap.php 漏洞问题
    discuzX3.4安装之后,没有任何样式怎么办?
    阿里云 RDS for MySQL支持什么引擎
    PHP随机生成要求位数个字符(大小写字母+数字)
    PHP json_decode为什么将json字符串转成数组是对象格式?
    PHP实用的功能函数
    css实现三角形图标
  • 原文地址:https://www.cnblogs.com/RioTian/p/13402638.html
Copyright © 2011-2022 走看看