zoukankan      html  css  js  c++  java
  • HDU1004 查气球

    Let the Balloon Rise

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 102132    Accepted Submission(s): 39192


    Problem Description
    Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges' favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color and find the result.

    This year, they decide to leave this lovely job to you.
     
    Input
    Input contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) -- the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters.

    A test case with N = 0 terminates the input and this test case is not to be processed.
     
    Output
    For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case.
     
    Sample Input
    5 green red blue red red 3 pink orange pink 0
     
    Sample Output
    red pink
     
    Author
    WU, Jiazhi
     
    Source
     
    Recommend
    JGShining   |   We have carefully selected several similar problems for you:  1008 1019 1021 1013 1012 
    #include <string.h>
    #include <iostream>
    #include <algorithm>
    #include <stdlib.h>
    #include <stdio.h>
    using namespace std;
    int main()
    {
        int i,j,n,t;
        while (cin>>n&&n)
        {
            char c[1005][20];
            int a[1005];
            memset(a,0,sizeof(a));
            for (i=0;i<n;i++)
            {
                cin>>c[i];
                for (j=0;j<i;j++)
                {
                    if (strcmp(c[i],c[j])==0)
                    a[i]++;
                }
            }
            int max=0,t=0;
            for (i=0;i<n;i++)
            {
                if (a[i]>max)
                {
                    max=a[i];
                    t=i;
                }
            }
            cout<<c[t]<<endl;
    
        }
    
    
    
        return 0;
    }
  • 相关阅读:
    jsp自定义标签
    spring JDBC 返回list<map>集合
    AWS 身份及验证服务(四)
    AWS 存储服务(三)
    AWS 核心服务概述(二)
    云计算和 AWS 概述(一)
    AWS 解决方案架构师考点(Storage)
    利用 AWS 无服务架构之语音合成
    AWS 云上安全最佳实践
    持续集成 Jenkins +Gitlab + SSH 自动发布 HTML 代码
  • 原文地址:https://www.cnblogs.com/Ritchie/p/5425308.html
Copyright © 2011-2022 走看看