zoukankan      html  css  js  c++  java
  • UESTC 1215 (思维题 旋转)

    Secrete Master Plan

    Time Limit: 3000/1000MS (Java/Others)     Memory Limit: 65535/65535KB (Java/Others)
     

    Master Mind KongMing gave Fei Zhang a secrete master plan stashed in a pocket. The plan instructs how to deploy soldiers on the four corners of the city wall. Unfortunately, when Fei opened the pocket he found there are only four numbers written in dots on a piece of sheet. The numbers form a 2×22×2 matrix, but Fei didn't know the correct direction to hold the sheet. What a pity!

    Given two secrete master plans. The first one is the master's original plan. The second one is the plan opened by Fei. As KongMing had many pockets to hand out, he might give Fei the wrong pocket. Determine if Fei receives the right pocket.

    title

    Input

    The first line of the input gives the number of test cases, TT(1T1041≤T≤104). TT test cases follow. Each test case contains 44 lines. Each line contains two integers ai0ai0 and ai1ai1 (1ai0,ai11001≤ai0,ai1≤100). The first two lines stands for the original plan, the 3rd3rd and 4th4th line stands for the plan Fei opened.

    Output

    For each test case, output one line containing Case #x: y, where xx is the test case number (starting from 11) and yy is either "POSSIBLE" or "IMPOSSIBLE" (quotes for clarity).

    Sample input and output

    Sample InputSample Output
    4
    1 2
    3 4
    1 2
    3 4
    
    1 2
    3 4
    3 1
    4 2
    
    1 2
    3 4
    3 2
    4 1
    
    1 2
    3 4
    4 3
    2 1
    Case #1: POSSIBLE
    Case #2: POSSIBLE
    Case #3: IMPOSSIBLE
    Case #4: POSSIBLE

    Source

    The 2015 China Collegiate Programming Contest
    #include <iostream>
    using namespace std;
    int main()
    {
        int t,a,b,c,d,x,y,z,w,tmp,k=1;
        cin>>t;
        while(t--)
        {
            int flag=0;
            cin>>a>>b>>d>>c;
            cin>>x>>y>>w>>z;
            while (a!=x||b!=y||d!=w||c!=z)
            {
                tmp=a;
                a=b;
                b=c;
                c=d;
                d=tmp;
                flag++;
                if (flag==4)
                break;
            }
            if (flag<4)
            {
                cout<<"Case #"<<k++<<": POSSIBLE"<<endl;
            }
            else
            cout<<"Case #"<<k++<<": IMPOSSIBLE"<<endl;
    
        }
        return 0;
    }
  • 相关阅读:
    DOM笔记(二):Node接口
    DOM笔记(一):HTMLDocument接口
    mysql_connect v/s mysql_pconnect
    HTML 5:绘制旋转的太极图
    HTML 5:你必须知道的data属性
    CSS:7个你可能不认识的单位
    CSS 3的display:盒类型详解
    PHP:6种GET和POST请求发送方法
    asp.net mvc生命周期学习
    关于sql row_number,rank,dense_rank,ntile函数
  • 原文地址:https://www.cnblogs.com/Ritchie/p/5425399.html
Copyright © 2011-2022 走看看