zoukankan      html  css  js  c++  java
  • poj 2318 TOYS (计算几何)

    B - TOYS
    Time Limit:2000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u
    Submit Status

    Description

    Calculate the number of toys that land in each bin of a partitioned toy box.
    Mom and dad have a problem - their child John never puts his toys away when he is finished playing with them. They gave John a rectangular box to put his toys in, but John is rebellious and obeys his parents by simply throwing his toys into the box. All the toys get mixed up, and it is impossible for John to find his favorite toys.

    John's parents came up with the following idea. They put cardboard partitions into the box. Even if John keeps throwing his toys into the box, at least toys that get thrown into different bins stay separated. The following diagram shows a top view of an example toy box.

    For this problem, you are asked to determine how many toys fall into each partition as John throws them into the toy box.

    Input

    The input file contains one or more problems. The first line of a problem consists of six integers, n m x1 y1 x2 y2. The number of cardboard partitions is n (0 < n <= 5000) and the number of toys is m (0 < m <= 5000). The coordinates of the upper-left corner and the lower-right corner of the box are (x1,y1) and (x2,y2), respectively. The following n lines contain two integers per line, Ui Li, indicating that the ends of the i-thcardboard partition is at the coordinates (Ui,y1) and (Li,y2). You may assume that the cardboard partitions do not intersect each other and that they are specified in sorted order from left to right. The next m lines contain two integers per line, Xj Yj specifying where the j-th toy has landed in the box. The order of the toy locations is random. You may assume that no toy will land exactly on a cardboard partition or outside the boundary of the box. The input is terminated by a line consisting of a single 0.

    Output

    The output for each problem will be one line for each separate bin in the toy box. For each bin, print its bin number, followed by a colon and one space, followed by the number of toys thrown into that bin. Bins are numbered from 0 (the leftmost bin) to n (the rightmost bin). Separate the output of different problems by a single blank line.

    Sample Input

    5 6 0 10 60 0
    3 1
    4 3
    6 8
    10 10
    15 30
    1 5
    2 1
    2 8
    5 5
    40 10
    7 9
    4 10 0 10 100 0
    20 20
    40 40
    60 60
    80 80
     5 10
    15 10
    25 10
    35 10
    45 10
    55 10
    65 10
    75 10
    85 10
    95 10
    0
    

    Sample Output

    0: 2
    1: 1
    2: 1
    3: 1
    4: 0
    5: 1
    
    0: 2
    1: 2
    2: 2
    3: 2
    4: 2
    

    Hint

    As the example illustrates, toys that fall on the boundary of the box are "in" the box.

    题意:有一个大箱子,由n个板分为n+1块,标号为0~n已知盒子左上角和右下角的坐标及每个板上下

       两端的横坐标(板不会交错,且按顺序给出)然后给出玩具的坐标,统计每块空间内玩具个数

       (保证玩具一定落在空间内)。

    题解:用二分法和叉积判断该点的位置。叉积:如果x1y2-x2y1等于0则线段12共线,如果差大于0,则2在1的逆时针方向,

       否则2在1的顺时针方向。用数组保存一下输出即可。

    #include <iostream>
    #include <stdio.h>
    #include <string.h>
    using namespace std;
    struct point{
        int x,y;
    };
    struct Line{
        point a,b;
    }line[5005];
    int cnt[5005];
    int Multi(point p1,point p2,point p0)
    {
        return (p1.x-p0.x)*(p2.y-p0.y)-(p2.x-p0.x)*(p1.y-p0.y);
    }
    void s(point a,int n)
    {
        int l=0,r=n-1,mid;
        while(l<r)
        {
            mid=(l+r)>>1;
            if(Multi(a,line[mid].a,line[mid].b)>0) l=mid+1;
            else r=mid;
        }
        if(Multi(a,line[l].a,line[l].b)<0)
            cnt[l]++;
        else
            cnt[l+1]++;
    }
    int main()
    {
        int n,m,x1,y1,x2,y2;
        int i,t1,t2;
        point a;
        while(cin>>n&&n)
        {
            cin>>m>>x1>>y1>>x2>>y2;
            for(int i=0;i<n;i++)
            {
                cin>>t1>>t2;
                line[i].a.x=t1;
                line[i].a.y=y1;
                line[i].b.x=t2;
                line[i].b.y=y2;
            }
            memset(cnt,0,sizeof(cnt));
            for(int i=0;i<m;i++)
            {
                cin>>a.x>>a.y;
                s(a,n);
            }
            for(int i=0;i<=n;i++)
            cout<<i<<": "<<cnt[i]<<endl;
            cout<<endl;
        }
        return 0;
    }
  • 相关阅读:
    离奇的软件开发之路
    集群环境中的单例设计模式
    Android 如何更换屏幕上锁界面背景图片
    基于华为Java编程规范的Eclipse checkStyle.xml
    对数据库事务的总结
    [Sciter系列] MFC下的Sciter–1.创建工程框架
    Android 如何添加一种锁屏方式
    Hibernate级联操作 注解
    linux就是这个范儿之融于心而表于行(1)
    Android 如何修改默认的searchable items。
  • 原文地址:https://www.cnblogs.com/Ritchie/p/5491749.html
Copyright © 2011-2022 走看看