zoukankan      html  css  js  c++  java
  • PTA 1034 Head of a Gang (图论写法)

    One way that the police finds the head of a gang is to check people's phone calls. If there is a phone call between A and B, we say that A and B is related. The weight of a relation is defined to be the total time length of all the phone calls made between the two persons. A "Gang" is a cluster of more than 2 persons who are related to each other with total relation weight being greater than a given threthold K. In each gang, the one with maximum total weight is the head. Now given a list of phone calls, you are supposed to find the gangs and the heads.

    Input Specification:

    Each input file contains one test case. For each case, the first line contains two positive numbers N and K (both less than or equal to 1000), the number of phone calls and the weight threthold, respectively. Then N lines follow, each in the following format:

    Name1 Name2 Time
    

    where Name1 and Name2 are the names of people at the two ends of the call, and Time is the length of the call. A name is a string of three capital letters chosen from A-Z. A time length is a positive integer which is no more than 1000 minutes.

    Output Specification:

    For each test case, first print in a line the total number of gangs. Then for each gang, print in a line the name of the head and the total number of the members. It is guaranteed that the head is unique for each gang. The output must be sorted according to the alphabetical order of the names of the heads.

    Sample Input 1:

    8 59
    AAA BBB 10
    BBB AAA 20
    AAA CCC 40
    DDD EEE 5
    EEE DDD 70
    FFF GGG 30
    GGG HHH 20
    HHH FFF 10
    

    Sample Output 1:

    2
    AAA 3
    GGG 3
    

    Sample Input 2:

    8 70
    AAA BBB 10
    BBB AAA 20
    AAA CCC 40
    DDD EEE 5
    EEE DDD 70
    FFF GGG 30
    GGG HHH 20
    HHH FFF 10
    

    Sample Output 2:

    0
    
    #include<iostream>
    #include<cstring>
    #include<string>
    #include<algorithm>
    #include<map>
    const int maxn = 2010;//定义最大人数 
    const int inf = 0x3fffffff;//定义最大值 
    using namespace std;
    
    map<int,string>intToString; //将数字转换成人名 
    map<string,int>stringToInt;//将人名转换成数字
    map<string,int>Gang;//记录头目名字与团队人数的映射 
    
    int G[maxn][maxn] = {0};//储存边权 
    int weight[maxn] ={0};//储存点权 
    int n,k,numPerson = 0;
    bool vis[maxn]={false};
    
    void dfs(int nowVisit , int &head,int &numMember ,int &totalValue)
    {
    	numMember++;//这个集团的总人数 
    	vis[nowVisit] = true;
    	if (weight[nowVisit] > weight[head])
    	{
    		head = nowVisit;
    	}
    	for (int i=0;i<numPerson;i++)
    	{
    		if (G[nowVisit][i]>0)
    		{
    			totalValue += G[nowVisit][i];
    			G[nowVisit][i] = G[i][nowVisit] = 0;
    			if (vis[i] == false)
    			{
    				dfs(i,head,numMember,totalValue);
    			}
    		}
    	}
    }
    
    void dfsTrave()
    {
    	for (int i=0;i<numPerson;i++)
    	{
    		if (vis[i]==false)
    		{
    			int head = i,numMember = 0,totalValue = 0;
    			dfs(i,head,numMember,totalValue);
    			if (numMember > 2 && totalValue > k)
    			{
    				Gang[intToString[head]] = numMember;
    			}
    		}
    	}
    }
    
    int change(string str)//将名字转换成数字映射 
    {
    	if (stringToInt.find(str) != stringToInt.end())
    	{
    		return stringToInt[str];//如果map中有这个名字,则返回这个名字对应的数字 
    	}
    	else
    	{
    		stringToInt[str] = numPerson;//如果map中没有名字,则添加 
    		intToString[numPerson] = str;
    		return numPerson++;//比如先输入AAA再输入BBB , 那么AAA对应的数字就是1,BBB、对应的数字就是2 
    	}
    }
    
    int main()
    {
    	int w;
    	string str1,str2;
    	cin>>n>>k;
    	for (int i=0;i<n;i++)
    	{
    		cin>>str1>>str2>>w;
    		int id1 = change(str1);
    		int id2 = change(str2);
    		weight[id1] += w;
    		weight[id2] += w;
    		G[id1][id2] += w;
    		G[id2][id1] += w;
    	}
    	dfsTrave();
    	cout<<Gang.size()<<endl;
    	map<string,int>::iterator it;
    	for (it = Gang.begin();it!=Gang.end();it++)
    	{
    		cout<<it->first<<" "<<it->second<<endl;
    	}
    	return 0;
    }
    
    
    
    
  • 相关阅读:
    所有选择器
    display:block、display:inline与displayinline:block的概念和区别
    jQuery 选择器
    JS日历制作获取时间
    HTML DOM 事件
    访问HTML元素(节点)
    HTML常用标签
    flask+mysql的Docker 部署
    docker(三)
    flask如何部署
  • 原文地址:https://www.cnblogs.com/Romantic-Chopin/p/12451184.html
Copyright © 2011-2022 走看看