zoukankan      html  css  js  c++  java
  • A + B Problem II JAVA大数水过

    Description

    I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.

    Input

    The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.

    Output

    For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.

    Sample Input

    
     

    2 1 2 112233445566778899 998877665544332211

    Sample Output

    
     

    Case 1: 1 + 2 = 3 Case 2: 112233445566778899 + 998877665544332211 = 1111111111111111110

    import java.math.BigInteger;
    import java.util.Scanner;
    public class Main {
     public static void main(String[] args) {
      Scanner input=new Scanner(System.in);
      int n=input.nextInt();
      int k=1;
      while(n!=0)
      {
       BigInteger a=input.nextBigInteger();
       BigInteger b=input.nextBigInteger();
          BigInteger c=a.add(b);
                        n--;
          if(k!=1)
           System.out.println();//输出换行
                System.out.println("Case "+k+":");
                k++;
          System.out.println(a+" + "+b+" = "+c);
      }
     }
    }
    
  • 相关阅读:
    面试题33:把数组排成最小的数
    面试题32:从1到n整数中1出现的次数
    面试题31:连续子数组的最大和
    HTTPS 及加密信息全解析
    面试题30:最小的k个数
    linux退出vi
    linux清除当前屏幕
    java web开发环境配置
    jQuery积累
    html5离线应用详摘
  • 原文地址:https://www.cnblogs.com/Romantic-Chopin/p/12451200.html
Copyright © 2011-2022 走看看