zoukankan      html  css  js  c++  java
  • ACM-ICPC 2018 焦作赛区网络预赛 I. Save the Room

    Bob is a sorcerer. He lives in a cuboid room which has a length of AA, a width of BB and a height of CC, so we represent it as AA * BB * CC. One day, he finds that his room is filled with unknown dark energy. Bob wants to neutralize all the dark energy in his room with his light magic. He can summon a 11 * 11 * 22 cuboid at a time to neutralize dark energy. But the cuboid must be totally in dark energy to take effect. Can you foresee whether Bob can save his room or not?

    Input

    Input has TT test cases. T le 100T≤100

    For each line, there are three integers A, B, CA,B,C.

    1 le A, B, C le 1001≤A,B,C≤100

    Output

    For each test case, if Bob can save his room, print"Yes", otherwise print"No".

    样例输入复制

    1 1 2
    1 1 4
    1 1 1

    样例输出复制

    Yes
    Yes
    No

    题目来源

    ACM-ICPC 2018 焦作赛区网络预赛

    题目意思是,有一个a*b*c大小的长方体,你用1*1*2大小的长方体来填充,填充过程中,不能超出a*b*c长方体的空间。问是否可以刚好填充。

    分析,因为是1*1*2大小,所以以1*1为底面填充一定可以把底面填满,那么只需要考虑高就好啦,然后发现,高是二的倍数就可以刚好填充。 

    #include<iostream>
    #include<cstring>
    using namespace std;
    
    int main()
    {
    	int a,b,c,n,m,j,k,i,T;
    	while (cin>>a>>b>>c)
    	{
    		if(a%2==0 || b%2==0 || c%2==0)
    		cout<<"Yes"<<endl;
    		else
    		cout<<"No"<<endl;
    	}
    	
    	return 0;
    }
  • 相关阅读:
    三十二、恢复单库单表
    三十一、XBK备份
    三十、分库分表备份脚本
    二十九、mysqldump恢复案例
    二十八、mysqldump备份
    二十七、备份介绍
    二十六:慢日志分析
    二十五、二进制日志之GTID模式
    Trie树
    AC自动机
  • 原文地址:https://www.cnblogs.com/Romantic-Chopin/p/12451420.html
Copyright © 2011-2022 走看看