zoukankan      html  css  js  c++  java
  • POJ 3070 Fibonacci【斐波那契数列/矩阵快速幂】

    Fibonacci
    Time Limit: 1000MS   Memory Limit: 65536K
    Total Submissions: 17171   Accepted: 11999

    Description

    In the Fibonacci integer sequence, F0 = 0, F1 = 1, and Fn = Fn − 1 + Fn − 2 for n ≥ 2. For example, the first ten terms of the Fibonacci sequence are:

    0, 1, 1, 2, 3, 5, 8, 13, 21, 34, …

    An alternative formula for the Fibonacci sequence is

    .

    Given an integer n, your goal is to compute the last 4 digits of Fn.

    Input

    The input test file will contain multiple test cases. Each test case consists of a single line containing n (where 0 ≤ n ≤ 1,000,000,000). The end-of-file is denoted by a single line containing the number −1.

    Output

    For each test case, print the last four digits of Fn. If the last four digits of Fn are all zeros, print ‘0’; otherwise, omit any leading zeros (i.e., print Fn mod 10000).

    Sample Input

    0
    9
    999999999
    1000000000
    -1

    Sample Output

    0
    34
    626
    6875

    Hint

    As a reminder, matrix multiplication is associative, and the product of two 2 × 2 matrices is given by

    .

    Also, note that raising any 2 × 2 matrix to the 0th power gives the identity matrix:

    .

    Source

    【分析】:矩乘其实很简单,通过自己构造或者是搜索对于一个递推公式求出它所对应的常数矩阵,然后套个快速幂就可以迅速求解第n项。最后输出的是矩阵最左上方的值。根据前面的一些思路,现在我们需要构造一个2 x 2的矩阵,使得它乘以(a,b)得到的结果是(b,a+b)。每多乘一次这个矩阵,这两个数就会多迭代一次。那么,我们把这个2 x 2的矩阵自乘n次,再乘以(0,1)就可以得到第n个Fibonacci数了。不用多想,这个2 x 2的矩阵很容易构造出来。
    【代码】:
    #include <iostream>
    #include <cstddef>
    #include <cstring>
    #include <vector>
    
    using namespace std;
    
    typedef long long ll;
    const int mod=10000;
    typedef vector<ll> vec;
    typedef vector <vec> mat;
    
    mat mul(mat &a,mat &b)
    {
        mat c(a.size(),vec(b[0].size()));
        for(int i=0;i<2;i++)
            for(int j=0;j<2;j++)
            for(int k=0;k<2;k++){
              c[i][j]+=a[i][k]*b[k][j];
              c[i][j]%=mod;
            }
            return c;
    }
    
    mat Pow(mat a,ll n)
    {
        mat res(a.size(),vec(a.size()));
        for(int i=0;i<a.size();i++)
            res[i][i]=1;
        while(n)
        {
            if(n&1)
                res=mul(res,a);
            a=mul(a,a);
            n/=2;
        }
        return res;
    }
    
    ll solve(ll n)
    {
        mat a(2,vec(2));
        a[0][0]=1;
        a[0][1]=1;
        a[1][0]=1;
        a[1][1]=0;
        a=Pow(a,n);
        return a[0][1];
    }
    
    int main()
    {
        ll n;
        while(cin>>n&&n!=-1)
        {
            cout<<solve(n)<<endl;
        }
    }
    斐波那契快速幂
  • 相关阅读:
    20165215 2017-2018-2 《Java程序设计》第4周学习总结
    20165215 2017-2018-2 《Java程序设计》第3周学习总结
    20165215 2017-2018-2 《Java程序设计》第2周学习总结
    20165215 第一次测试总结
    20165215 2017-2018-2《Java程序设计》第一周学习总结
    20165215 预备作业3 Linux安装及学习
    20165215 学习基础和c语言基础调查
    20165215 我期望的师生关系
    20165220 Java第三周学习总结
    20165220预备作业3 Linux安装及学习
  • 原文地址:https://www.cnblogs.com/Roni-i/p/8350614.html
Copyright © 2011-2022 走看看