zoukankan      html  css  js  c++  java
  • HDU 1022 Train Problem I[给出两个长n的串,入栈和出栈顺序,判断入栈顺序是否可以匹配出栈顺序]

    Train Problem I

    时间限制:3000 ms  |  内存限制:65535 KB
    难度:2
    描述
    As the new term comes, the Ignatius Train Station is very busy nowadays. A lot of student want to get back to school by train(because the trains in the Ignatius Train Station is the fastest all over the world ^v^). But here comes a problem, there is only one railway where all the trains stop. So all the trains come in from one side and get out from the other side. For this problem, if train A gets into the railway first, and then train B gets into the railway before train A leaves, train A can't leave until train B leaves. The pictures below figure out the problem. Now the problem for you is, there are at most 9 trains in the station, all the trains has an ID(numbered from 1 to n), the trains get into the railway in an order O1, your task is to determine whether the trains can get out in an order O2.
    输入
    The input contains several test cases. Each test case consists of an integer, the number of trains, and two strings, the order of the trains come in:O1, and the order of the trains leave:O2. The input is terminated by the end of file. More details in the Sample Input.
    输出
    The output contains a string "No." if you can't exchange O2 to O1, or you should output a line contains "Yes.", and then output your way in exchanging the order(you should output "in" for a train getting into the railway, and "out" for a train getting out of the railway). Print a line contains "FINISH" after each test case. More details in the Sample Output.
    样例输入
    3 123 321
    3 123 312
    
    样例输出
    Yes.
    in
    in
    in
    out
    out
    out
    FINISH
    No.
    FINISH
    [题意]:给出两个长n的串,入栈和出栈顺序.判断是否可以.
    [分析]:

    比较坑的一点就是 str2的长度可能大于str1. 于是str1[i] 压入栈标记为1 如果栈顶==str2[j] 就出栈 j++ 标记为0

    j==n yes,否则 no


    [代码]:
    #include <bits/stdc++.h>
    using namespace std;
    const int N=200;
    int main()
    {
        int n,vis[N];
        char s1[N],s2[N];
        stack<char> st;
        while(cin>>n>>s1>>s2)
        {
            while(!st.empty()) st.pop();//清空栈
            memset(vis,0,sizeof(vis));
            int j=0,k=0; //k记录路径数,vis标记路径
            for(int i=0;i<n;i++)
            {
                st.push(s1[i]);
                vis[k++]=1;
                while(!st.empty() && st.top()==s2[j])
                {
                    st.pop();
                    vis[k++]=0;
                    j++;
                }
            }
            if(j==n)
            {
                puts("Yes.");
                for(int i=0;i<k;i++) //k记录路径数,vis标记路径
                    puts(vis[i]?"in":"out");
                puts("FINISH");
            }
            else
                printf("No.
    FINISH
    ");
        }
    }
    /*
    3
    123 213
    Yes.
    in
    in
    out
    out
    in
    out
    FINISH
    */
    View Code
  • 相关阅读:
    poj 2195 Going Home
    poj 3068 "Shortest" pair of paths
    aoj 2226 Merry Christmas
    poj 2226 Muddy Fields
    foj Problem 2275 Game
    foj Problem 2283 Tic-Tac-Toe
    XidianOJ 1081 锘爷与矩阵
    XidianOJ 1061 a+boflw
    XidianOJ 1080 锘爷与跳楼塔
    XidianOJ 1017 Codeforce上的rating
  • 原文地址:https://www.cnblogs.com/Roni-i/p/8417863.html
Copyright © 2011-2022 走看看