zoukankan      html  css  js  c++  java
  • Doki Doki Literature Club

    Doki Doki Literature Club! is a visual novel developed by Team Salvato. The protagonist is invited by his childhood friend, Sayori, to join their high school's literature club. The protagonist then meets the other members of the club: Natsuki, Yuri, and the club president Monika. The protagonist starts to participate in the club's activities such as writing and sharing poetry, and grows close to the four girls. What a lovely story!【这段都是背景,我r】

    A very important feature of the game is its poetry writing mechanism. The player is given a list of various words to select from that will make up his poem. Each girl in the Literature Club has different word preferences, and will be very happy if the player's poem is full of her favorite words.

    The poem writing mini-game (from wikipedia)

    BaoBao is a big fan of the game and likes Sayori the most, so he decides to write a poem to please Sayori. A poem of words is nothing more than a sequence of strings, and the happiness of Sayori after reading the poem is calculated by the formula
    where is the happiness and is Sayori's preference to the word .

    Given a list of words and Sayori's preference to each word, please help BaoBao select words from the list and finish the poem with these words to maximize the happiness of Sayori.

    Please note that each word can be used at most once!

    Input
    There are multiple test cases. The first line of input contains an integer (about 100), indicating the number of test cases. For each test case:

    The first line contains two integers and (), indicating the number of words and the length of the poem.

    For the following lines, the -th line contains a string consisting of lowercased English letters () and an integer (), indicating the -th word and Sayori's preference to this word. It's guaranteed that for all .

    Output
    For each test case output one line containing an integer and strings separated by one space, indicating the maximum possible happiness and the corresponding poem. If there are multiple poems which can achieve the maximum happiness, print the lexicographically smallest one.

    Please, DO NOT output extra spaces at the end of each line, or your answer may be considered incorrect!

    A sequence of strings is lexicographically smaller than another sequence of strings , if there exists a () such that for all and is lexicographically smaller than .

    A string is lexicographically smaller than another string , if there exists a () such that for all and , or for all and .

    Sample Input
    4
    10 8
    hello 0
    world 0
    behind 0
    far 1
    be 2
    spring 10
    can 15
    comes 20
    winter 25
    if 200
    5 5
    collegiate 0
    programming -5
    zhejiang 10
    provincial 5
    contest -45
    3 2
    bcda 1
    bcd 1
    bbbbb 1
    3 2
    a 1
    aa 1
    aaa 1
    Sample Output
    2018 if winter comes can spring be far behind
    15 zhejiang provincial collegiate programming contest
    3 bbbbb bcd
    3 a aa

    #include<bits/stdc++.h>
    using namespace std;
    #define ll long long
    struct node
    {
        string s;
        int w;
    }a[1005];
    
    int cmp(node a,node b)
    {
        if(a.w!=b.w) return a.w>b.w;
        return a.s<b.s;
    }
    vector<string> v;
    int n,m;
    int main()
    {
        int t;
        scanf("%d",&t);
        while(t--)
        {
            v.clear();
            ll h=0;
            scanf("%d%d",&n,&m);
            for(int i=0;i<n;i++)
            {
                cin>>a[i].s>>a[i].w;
            }
            sort(a,a+n,cmp);
            for(lli=0;i<m;i++)
            {
                v.push_back(a[i].s);
                h += (m-i)*a[i].w;
            }
            cout<<h;
            for(int i=0;i<m;i++)
            {
                 cout<<" "<<v[i];
            }
            cout<<endl;
        }
    }
    
    
  • 相关阅读:
    ASP.NET页面优化,提高载入速度[转]
    winform app.config文件的动态配置
    ASP.NET 程序中删除文件夹导致session失效解决问题
    ASP.NET网站版本自动更新程序及代码[转]
    swf2pdf转swf时字符集问题【转】
    ASP.NET中EVAL用法大全
    安装sqlserver2012时出现的丧心病狂的错误
    sqlserver2008清日志
    搭建了个静态资源服务器遇到的问题与解决
    获取action name在asp.net mvc
  • 原文地址:https://www.cnblogs.com/Roni-i/p/8971048.html
Copyright © 2011-2022 走看看