zoukankan      html  css  js  c++  java
  • HUD 1686 Oulipo(KMP)

    Problem Description
    The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter 'e'. He was a member of the Oulipo group. A quote from the book:

    Tout avait Pair normal, mais tout s’affirmait faux. Tout avait Fair normal, d’abord, puis surgissait l’inhumain, l’affolant. Il aurait voulu savoir où s’articulait l’association qui l’unissait au roman : stir son tapis, assaillant à tout instant son imagination, l’intuition d’un tabou, la vision d’un mal obscur, d’un quoi vacant, d’un non-dit : la vision, l’avision d’un oubli commandant tout, où s’abolissait la raison : tout avait l’air normal mais…

    Perec would probably have scored high (or rather, low) in the following contest. People are asked to write a perhaps even meaningful text on some subject with as few occurrences of a given “word” as possible. Our task is to provide the jury with a program that counts these occurrences, in order to obtain a ranking of the competitors. These competitors often write very long texts with nonsense meaning; a sequence of 500,000 consecutive 'T's is not unusual. And they never use spaces.

    So we want to quickly find out how often a word, i.e., a given string, occurs in a text. More formally: given the alphabet {'A', 'B', 'C', …, 'Z'} and two finite strings over that alphabet, a word W and a text T, count the number of occurrences of W in T. All the consecutive characters of W must exactly match consecutive characters of T. Occurrences may overlap.

     
    Input
    The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format:

    One line with the word W, a string over {'A', 'B', 'C', …, 'Z'}, with 1 ≤ |W| ≤ 10,000 (here |W| denotes the length of the string W).
    One line with the text T, a string over {'A', 'B', 'C', …, 'Z'}, with |W| ≤ |T| ≤ 1,000,000.
     
    Output
    For every test case in the input file, the output should contain a single number, on a single line: the number of occurrences of the word W in the text T.

     
    Sample Input
    3 BAPC BAPC AZA AZAZAZA VERDI AVERDXIVYERDIAN
     
    Sample Output
    1 3 0
     
    Source
    #include<bits/stdc++.h>
    using namespace std;
    #define ll long long
    
    const ll inf = 2000000000000;
    const int mod = 1000000007;
    const int maxn = 1000000 + 8;
    
    int k, t, ne[maxn], num;
    
    string a, b;
    
    void getnext()
    {
        ne[0] = ne[1] = 0;
        int len = a.size();
        for(int i = 1; i < len; i++)
        {
            int j = ne[i];
            while(j && a[i] != a[j])///寻找与这个字母相同的字母,若找不到,就一直往前跳
                j = ne[j];
            ne[i + 1] = a[i] == a[j] ? j + 1 : 0;///如果两个字母相同,则i和j都加加;否则j = 0,重新比较
        }
    }
    
    void kmp()
    {
        int j = 0, len1 = a.size(), len2 = b.size();
        for(int i = 0; i < len2; i++)
        {
            while(j && a[j] != b[i])///寻找两个字母都相同的字母,如果找不到相同的,就一直往前跳
                j = ne[j];
            if(a[j] == b[i])///如果找到相同的,就让字符的对应下标++
               j++;
            if(j == len1)///如果字符此时的下标已经等于a的长度,就记一下数
                num++;
        }
    }
    
    int main()
    {
        std::ios::sync_with_stdio(0);
        cin.tie(0);
        cout.tie(0);
        cin >> t;
        while(t--)
        {
            num = 0;
            memset(ne, 0, sizeof(ne));
            cin >> a;
            cin >> b;
            getnext();
            kmp();
            cout << num << '
    ';
        }
        return 0;
    }
  • 相关阅读:
    预备作业2
    预备作业
    虚拟机安装&Linux初探
    20155330预备作业2:做中学——实践中思考
    预备作业:你期望的师生关系是什么?
    2017-2018-1 学号20155329 《信息安全系统设计基础》第5周学习总结
    2017-2018-1 学号20155329_5332_5302《信息安全系统设计基础》实验一 开发环境的熟悉
    再装虚拟机及git
    2017-2018-1 学号20155329 《信息安全系统设计基础》第4周学习总结
    2017-2018-1 学号20155329 《信息安全系统设计基础》第4周学习总结
  • 原文地址:https://www.cnblogs.com/RootVount/p/11650457.html
Copyright © 2011-2022 走看看