zoukankan      html  css  js  c++  java
  • 1964-NP

    描述

     

    Problems in Computer Science are often classified as belonging to a certain class of problems (e.g., NP, Unsolvable, Recursive). In this problem you will be analyzing a property of an algorithm whose classification is not known for all possible inputs.

    Consider the following algorithm:

        1.      input n

        2.      print n

        3.      if n = 1 then STOP

        4.           if n is odd then n ← 3n + 1

        5.           else n ← n / 2

        6.      GOTO 2

    Given the input 22, the following sequence of numbers will be printed 22 11 34 17 52 26 13 40 20 10 5 16 8 4 2 1

    It is conjectured that the algorithm above will terminate (when a 1 is printed) for any integral input value. Despite the simplicity of the algorithm, it is unknown whether this conjecture is true. It has been verified, however, for all integers n such that 0 < n < 1,000,000 (and, in fact, for many more numbers than this.)

    Given an input n, it is possible to determine the number of numbers printed (including the 1). For a given n this is called the cycle-length of n. In the example above, the cycle length of 22 is 16.

    For any two numbers i and j you are to determine the maximum cycle length over all numbers between i and j. 

    输入

     

    The input will consist of a series of pairs of integers i and j, one pair of integers per line. All integers will be less than 1,000,000 and greater than 0.

    You should process all pairs of integers and for each pair determine the maximum cycle length over all integers between and including i and j.

    You can assume that no opperation overflows a 32-bit integer.

    输出

    For each pair of input integers i and j you should output i, j, and the maximum cycle length for integers between and including i and j. These three numbers should be separated by at least one space with all three numbers on one line and with one line of output for each line of input. The integers i and j must appear in the output in the same order in which they appeared in the input and should be followed by the maximum cycle length (on the same line).

    样例输入

    1 10

    100 200

    201 210

    900 1000

    样例输出

    1 10 20

    100 200 125

    201 210 89

    900 1000 174

    #include<iostream>
    using namespace std;
    void swap(int &a,int &b)
    {
        int tmp=a;
        a=b;
        b=tmp;
    }
    int np(int x)
    {
        int count=1;
        while(x!=1)
        {
            count++;
            if(x%2==0) x/=2;
            else x=3*x+1;
        }
        return count;
    }
    int solve(int s, int e)
    {
        int res=0,i,tmp;
        if(s>e)
            swap(s,e);
        for(i=s;i<=e;++i)
        {
            tmp=np(i);
            if(res<tmp)
                res=tmp;
        }
        return res;
    }
    int main()
    {
        int x,y,i;
        while(cin>>x>>y)
        {
            cout<<x<<" "<<y<<" "<<solve(x,y)<<endl;
        }
        return 0;
    } 
    

      

  • 相关阅读:
    Web安全测试
    性能测试---并发用户计算
    浅谈软件性能测试中关键指标的监控与分析
    fiddler抓包——IOS
    Linux下查看CPU型号,内存大小,硬盘空间,进程等的命令(详解)
    windows 升级pip
    java 使用Iterator 迭代器遍历AList、Set、Map
    springboot 封装redis工具类
    idea 取消@Autowired 不建议字段注入的警告
    查看服务器相关
  • 原文地址:https://www.cnblogs.com/Rosanna/p/3438666.html
Copyright © 2011-2022 走看看