zoukankan      html  css  js  c++  java
  • POJ 1273 Drainage Ditches 【费用流】

    题面:

    Description

    Every time it rains on Farmer John's fields, a pond forms over Bessie's favorite clover patch. This means that the clover is covered by water for awhile and takes quite a long time to regrow. Thus, Farmer John has built a set of drainage ditches so that Bessie's clover patch is never covered in water. Instead, the water is drained to a nearby stream. Being an ace engineer, Farmer John has also installed regulators at the beginning of each ditch, so he can control at what rate water flows into that ditch. 
    Farmer John knows not only how many gallons of water each ditch can transport per minute but also the exact layout of the ditches, which feed out of the pond and into each other and stream in a potentially complex network. 
    Given all this information, determine the maximum rate at which water can be transported out of the pond and into the stream. For any given ditch, water flows in only one direction, but there might be a way that water can flow in a circle. 

    Input

    The input includes several cases. For each case, the first line contains two space-separated integers, N (0 <= N <= 200) and M (2 <= M <= 200). N is the number of ditches that Farmer John has dug. M is the number of intersections points for those ditches. Intersection 1 is the pond. Intersection point M is the stream. Each of the following N lines contains three integers, Si, Ei, and Ci. Si and Ei (1 <= Si, Ei <= M) designate the intersections between which this ditch flows. Water will flow through this ditch from Si to Ei. Ci (0 <= Ci <= 10,000,000) is the maximum rate at which water will flow through the ditch.

    Output

    For each case, output a single integer, the maximum rate at which water may emptied from the pond.

    Sample Input

    5 4

    1 2 40

    1 4 20

    2 4 20

    2 3 30

    3 4 10

    Sample Output

    50

    题目大意:

    有一个有向图有n条路,m个点。每一条路都有最大承载能力。

    问最多能从第一个点传递多少东西到最后一个点

    大致思路:

    最大流模板题,通过这个题可以较好的理解最大流算法和实现过程

    关于最大流的思想参见kuangbin神犇的博客:http://www.cnblogs.com/kuangbin/archive/2011/07/26/2117636.html

    代码:

    #include<iostream>
    #include<cstdlib>
    #include<queue>
    #include<algorithm>
    #include<cstring>
    #include<cstdio>
    using namespace std;
    const int maxn=250;
    const int INF=1<<29;
    int n,m,start,tar;
    int g[maxn][maxn];
    int path[maxn],flow[maxn];
    queue<int> q;
    int bfs()
    {
        int u;
        while(!q.empty()) q.pop();//记得将队列清空
        memset(path,-1,sizeof(path));
        path[start]=0;
        flow[start]=INF;
        q.push(start);
        while(!q.empty())
        {
            u=q.front();
            q.pop();
            if(u==tar)
                break;
            for(int i=1;i<=m;++i){
                if(i!=start && path[i]==-1 && g[u][i]){
                    //flow[i]= flow[u]<g[u][i]?flow[u]:g[u][i];
                    flow[i]=min(flow[u],g[u][i]);
                    q.push(i);
                    path[i]=u;
                }
            }
        }
        if(path[tar]==-1)//若path[tar]未更新,则代表增广路径不存在
            return -1;
        return flow[tar];
    }
    int Edmonds_Karp()
    {
        int max_flow=0,step,now,pre;
        while(1)
        {
            step=bfs();//每次寻找是否还有增广路径
            if(step==-1)
                break;
            max_flow+=step;
            now=tar;
            while(now!=start)
            {
                pre=path[now];
                g[pre][now]-=step;
                g[now][pre]+=step;//增加反向边
                now=pre;
            }
        }
        return max_flow;
    }
    int main()
    {
        ios::sync_with_stdio(false);
        int u,v,l;
        //freopen("in.txt","r",stdin);
        while(cin>>n>>m)
        {
            memset(g,0,sizeof(g));
            for(int i=0;i<n;++i){
                cin>>u>>v>>l;
                g[u][v]+=l;
            }
            start=1;
            tar=m;
            cout<<Edmonds_Karp()<<endl;
        }
    
        return 0;
    }
  • 相关阅读:
    mysql8.0.20安装
    MySQL EXPLAIN结果集分析
    初次安装aliSql
    升级vim到8.0
    REPL环境对语言的帮助
    Python环境搭建及pip的使用
    mysql数据库分库分表(Sharding)
    Git的使用
    Promise的初步认识
    对引用的文件起别名
  • 原文地址:https://www.cnblogs.com/SCaryon/p/7517472.html
Copyright © 2011-2022 走看看