zoukankan      html  css  js  c++  java
  • 每日一练ACM 2019.04.13

    2019.04.13

    第1002题:A+B Proble Ⅱ

    Problem Description
    I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.
    Input
    The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
    Output
    For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.
    Sample Input
    2
    1 2
    112233445566778899 998877665544332211
    Sample Output
    Case 1:
    1 + 2 = 3

    Case 2:
    112233445566778899 + 998877665544332211 = 1111111111111111110


    题目解析:
    输入的第一行:T为实例的数量,再输入T行的例子,每行有2个正整数(他们很大,所以不能用32位的整数来表示),要求计算两个数的和并输出,保证输入的每个整数的长度不超过1000。

    解:

    package Acm;
    
    import java.math.BigInteger;
    import java.util.Scanner;
    
    public class test3 {
    
        public static void main(String[] args) {
            // TODO Auto-generated method stub
            Scanner input=new Scanner(System.in);
            int n=input.nextInt();
            for(int i=0;i<n;i++)
            {
                BigInteger a=input.nextBigInteger();
                BigInteger b=input.nextBigInteger();
                if(i==n-i)
                {    
                    System.out.print("case"+(i+1)+"
    "+a+"+"+b+"="+a.add(b));
                    
                }
                else
                {
                    System.out.println("case"+(i+1)+"
    "+a+"+"+b+"="+a.add(b));
                }
            }
        }
    
    }
  • 相关阅读:
    Python3爬取前程无忧数据分析工作并存储到MySQL
    MySQL操作数据库和表的基本语句(DDL
    MyBatis的增删改查操作
    指定方向或者位置移动
    AI-Tank
    转载人家写的CURSOR
    Ajax学习整理笔记
    全面解析注解
    java调用存储过程mysql
    JAVA如何调用mysql写的存储过程
  • 原文地址:https://www.cnblogs.com/SGRBOY/p/10708963.html
Copyright © 2011-2022 走看看