zoukankan      html  css  js  c++  java
  • 浙大pat---1036 Boys vs Girls (25)

    This time you are asked to tell the difference between the lowest grade of all the male students and the highest grade of all the female students.

    Input Specification:

    Each input file contains one test case. Each case contains a positive integer N, followed by N lines of student information. Each line contains a student's name, gender, ID and grade, separated by a space, where name and ID are strings of no more than 10 characters with no space, gender is either F (female) or M (male), and grade is an integer between 0 and 100. It is guaranteed that all the grades are distinct.

    Output Specification:

    For each test case, output in 3 lines. The first line gives the name and ID of the female student with the highest grade, and the second line gives that of the male student with the lowest grade. The third line gives the difference grade~F~-grade~M~. If one such kind of student is missing, output "Absent" in the corresponding line, and output "NA" in the third line instead.

    Sample Input 1:

    3
    Joe M Math990112 89
    Mike M CS991301 100
    Mary F EE990830 95
    

    Sample Output 1:

    Mary EE990830
    Joe Math990112
    6
    

    Sample Input 2:

    1
    Jean M AA980920 60
    

    Sample Output 2:

    Absent
    Jean AA980920
    NA
    题目解析:
    这题就考基础的模拟,使用结构体封装并手动找出最大最小值即可,水题!
    #include <iostream>
    #include <vector>
    #include <string.h>
    #include <algorithm>
    #define MAX 101
    using namespace std;
    struct student
    {
        string name;
        char gender;
        string id;
        int grade;
    };
    vector<student> male;
    vector<student> female;
    int main() {
        bool flag = false;
        int n;
        cin>>n;
        for(int i=0;i<n;i++)
        {
            student temp;
            cin>>temp.name;
            cin>>temp.gender;
            cin>>temp.id>>temp.grade;
            if(temp.gender=='M')
            {
                male.push_back(temp);
            }
            else{
                female.push_back(temp);
            }
        }
        int max = -1;
        int mim = MAX;
        int female_index;
        int male_index;
        //female highest
        for(int i=0;i<female.size();i++)
        {
            if(max<female[i].grade)
            {
                max = female[i].grade;
                female_index = i;
            }
        }
        for(int i=0;i<male.size();i++)
        {
            if(mim>male[i].grade)
            {
                mim = male[i].grade;
                male_index = i;
            }
        }
        if(max == -1)
        {
            cout<<"Absent"<<endl;
            flag = true;
        }
        else{
            cout<<female[female_index].name<<" "<<female[female_index].id<<endl;
        }
        if(mim == MAX)
        {
            cout<<"Absent"<<endl;
            flag = true;
        }
        else{
            cout<<male[male_index].name<<" "<<male[male_index].id<<endl;
        }
        if(flag)
        {
            cout<<"NA"<<endl;
        }
        else{
            cout<<female[female_index].grade - male[male_index].grade<<endl;
        }
    
        return 0;
    }
    

      

  • 相关阅读:
    【新特性速递】数字输入框的前缀和后缀(位于输入框内部)
    【新特性速递】进度条,进度条,进度条
    【新特性速递】当法语遇上FineUI(Bonjour)!
    【新特性速递】自定义数字输入框的小数分隔符和千分位分隔符
    【经验分享】FineUICore中如何处理文件导出异常?
    【网友作品】服装分销系统架构与界面分享(基于FineUICore基础版)
    FineUIPro/Mvc/Core v6.3.0 正式发布了!
    星球居民突破 1700 人!
    【新特性速递】开关样式复选框增强!
    【新特性速递】为RenderField新增QuickSortField属性!
  • 原文地址:https://www.cnblogs.com/SK1997/p/9384292.html
Copyright © 2011-2022 走看看