zoukankan      html  css  js  c++  java
  • Carneginon (The Preliminary Contest for ICPC Asia Xuzhou 2019)

    Carneginon was a chic bard. But when he was young, he was frivolous and had joined many gangs. Recently, Caneginon was to be crowned, because the king was shocked by his poems and decided to award him the gold medal lecturer. Therefore, Most of people in the Kingdom came to visit him.

    However, as a medal lectirer, Carneginon must treat the visitors kindly, including elders and younger generations. In order to maintain order, every visitor received a license with a magic field engraved on it. And the magic field on the licence was made up of lowercase letters.

    Carneginon had a unique licence, which could judge whether others are his older or younger. Now, we assume that the sequence on Carneginon's licence is TT and the sequence on visitors' licence is SS. For each visitor,

    • If the length of TT is longer than the length of SS, it's obviously that the visitor is younger. And if SS is a substring of TT, Carneginon would call the visitor my child!. Otherwise, Carneginon would call the visitor oh, child!.

    • If the length of TT is less than the length of SS, it's obviously that the visitor is elder. And if TT is a substring of SS, Carneginon would call the visitor my teacher!. Otherwise, Carneginon would call the visitor senior!.

    • Of course, if the length of TT is equal to the length of SS, the visitor is Carneginon's peer. And if TT is equal to SS, it shows that the visitor entered through an improper way and Carneginon would shout jntm!. Otherwise, Carneginon would call the visitor friend!.

    Now, you know the TT (Carneginon's licence), qq (the number of visitors) and each visitor's licence(S_iSi). Can you judge what Caneginon needs to say when he sees every visitor?

    Input

    The first line is a string TT, representing Carneginon's license.

    The second line is and integer qq, which means the number of visitors.

    Then mm lines, for each line, there is a string SS, denoting the visitor's license.

    1 leq |T| leq 10^51T105, 1 leq |S| leq 10^51S105, 1 leq q leq 10001q1000

    It is guaranteed that q imes (|S|+|T|) leq 10^7q×(S+T)107.

    Output

    There are qq lines.

    For each SS, output what Carneginon should say correctly.

    样例输入

    abcde
    6
    abcde
    aaaaa
    abcd
    aaaa
    abcdef
    abccdefg

    样例输出

    jntm!
    friend!
    my child!
    oh, child!
    my teacher!
    senior!

    KMP也能AC
    #include <iostream>
    #include <algorithm>
    #include <cmath>
    
    using namespace std;
    
    int main()
    {
        std::ios::sync_with_stdio(false);
        long long n;
        string s,a;
        while(cin>>s>>n)
        {
            int ls=s.size();
            while(n--)
            {
                cin>>a;
                int la=a.size();
                if(ls==la)
                {
                    if(s==a)
                        cout<<"jntm!"<<endl;
                    else
                        cout<<"friend!"<<endl;
                }
                else if(ls<la)
                {
                    if(a.find(s)!=a.npos)
                        cout<<"my teacher!"<<endl;
                    else
                        cout<<"senior!"<<endl;
    
                }
                else
                {
                    if(s.find(a)!=s.npos)
                        cout<<"my child!"<<endl;
                    else
                        cout<<"oh, child!"<<endl;
                }
            }
        }
        return 0;
    }
    所遇皆星河
  • 相关阅读:
    多线程
    异常
    接口
    多态
    对象和封装
    DIV+CSS命名规范集合
    MySql 最新官方安装教程-下载
    乐嘉性格色彩-4色特性,学习感悟
    Eclipse 的常用快捷方式
    学习方法_2011年编写和锻炼的思维题
  • 原文地址:https://www.cnblogs.com/Shallow-dream/p/11482835.html
Copyright © 2011-2022 走看看