zoukankan      html  css  js  c++  java
  • HDU 1018:Big Number (位数递推公式)

    Problem Description
    In many applications very large integers numbers are required. Some of these applications are using keys for secure transmission of data, encryption, etc. In this problem you are given a number, you have to determine the number of digits in the factorial of the number.

    Input
    Input consists of several lines of integer numbers. The first line contains an integer n, which is the number of cases to be tested, followed by n lines, one integer 1 ≤ n ≤ 107 on each line.

    Output
    The output contains the number of digits in the factorial of the integers appearing in the input.

    Sample Input
    2
    10
    20

    Sample Output
    7
    19

    #include <cstdio>
    #include <string.h>
    #define N 1024
    #define MAXN 0x3f3f3f3f
    #include <map>
    #include <string>
    #include <cmath>
    #define pi acos(-1.0)
    #include <algorithm>
    #include <iostream>
    #include <iomanip>
    #include <set>
    using namespace std;
    int main()
    {
        int n,m,t;
        cin>>t;
        while(t--)
        {
            double sum=0;
            cin>>n;
            for(double i=1;i<=n;i++)
                sum+=log10(i);
            cout<<(int)sum+1<<endl;
    
        }
        return 0;
    }
    所遇皆星河
  • 相关阅读:
    课堂检测求一个数的各个位
    猜数字
    登录界面
    课后作业01
    java语言基础问题
    大道至简第一张用java撰写伪代码
    阅读“大道至简”的读后感
    iOS 瀑布流的基本原理
    iOS 生成二维码
    CNContact对通讯录的基本使用(第二篇)
  • 原文地址:https://www.cnblogs.com/Shallow-dream/p/11610481.html
Copyright © 2011-2022 走看看