zoukankan      html  css  js  c++  java
  • HDU 1002: A + B Problem II (大数加法)


    Problem Description
    I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.

    Input
    The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.

    Output
    For each test case, you should output two lines. The first line is “Case #:”, # means the number of the test case. The second line is the an equation “A + B = Sum”, Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.

    Sample Input
    2
    1 2
    112233445566778899 998877665544332211

    Sample Output
    Case 1:
    1 + 2 = 3

    Case 2:
    112233445566778899 + 998877665544332211 = 1111111111111111110

    #include<iostream>
    #include<algorithm>
    #include<string.h>
    #include<vector>
    #include<cstring>
    #include<cstdlib>
    using namespace std;
    const int maxn = 1024;
    char str1[maxn], str2[maxn];
    int  array_1[maxn], array_2[maxn];
    void sum()
    {
        for(int i = strlen(str1) - 1, j = 0; i >= 0; i--)
            array_1[j++] = str1[i] - '0';
        for(int i = strlen(str2) - 1, j = 0; i >= 0; i--)
            array_2[j++] = str2[i] - '0';
      
        for(int i = 0; i < maxn; i++)
        {
            array_2[i] += array_1[i];
            if(array_2[i] >= 10)
            {
                array_2[i + 1] += array_2[i] / 10;
                array_2[i] %= 10;
            }
        }
          cout<<str1<<" + "<<str2<<" = ";
        int k=strlen(str1)>strlen(str2)?strlen(str1):strlen(str2) ;
        for( k=k ; k >= 0 && array_2[k] == 0; k--);
            if(k >= 0)
                for( ; k >= 0; k--)
                    cout << array_2[k];
            else
                cout << 0;
        cout << endl;
    }
      
    int main()
    {
        int t;
        cin>>t;
        for(int i=1;i<=t;i++)
        {
    
            memset(array_1, 0, sizeof(array_1));
            memset(array_2, 0, sizeof(array_2));
            memset(str1, 0, sizeof(str1));
            memset(str2, 0, sizeof(str2));
            cin >> str1 ;
            cin >> str2 ;
            cout<<"Case "<<i<<":"<<endl;
            sum();
            if(i!=t)
                cout<<endl;
        }
        
        return 0;
    }
    所遇皆星河
  • 相关阅读:
    【python】UI自动化框架搭建.优化
    【fiddler】mock测试
    【postman】对于postman简单的理解
    【pycharm】报错:windows找不到文件chrome
    【python】UI自动化操作属于div标签的滚动条滚动
    【fiddler】fiddler监听local host和127.0.0.1
    【PLSQL】PLSQL过期解决方案(注册机或者修改注册表)
    【奇怪的知识四】:一些常用的下载网站地址
    【奇怪的知识三】:一个可以变色的心形.bat
    python中request获取json数据
  • 原文地址:https://www.cnblogs.com/Shallow-dream/p/11610485.html
Copyright © 2011-2022 走看看