zoukankan      html  css  js  c++  java
  • B

    My birthday is coming up and traditionally I'm serving pie. Not just one pie, no, I have a number N of them, of various tastes and of various sizes. F of my friends are coming to my party and each of them gets a piece of pie. This should be one piece of one pie, not several small pieces since that looks messy. This piece can be one whole pie though.

    My friends are very annoying and if one of them gets a bigger piece than the others, they start complaining. Therefore all of them should get equally sized (but not necessarily equally shaped) pieces, even if this leads to some pie getting spoiled (which is better than spoiling the party). Of course, I want a piece of pie for myself too, and that piece should also be of the same size.

    What is the largest possible piece size all of us can get? All the pies are cylindrical in shape and they all have the same height 1, but the radii of the pies can be different.

    Input

    One line with a positive integer: the number of test cases. Then for each test case:
    • One line with two integers N and F with 1 ≤ N, F ≤ 10 000: the number of pies and the number of friends.
    • One line with N integers ri with 1 ≤ ri ≤ 10 000: the radii of the pies.

    Output

    For each test case, output one line with the largest possible volume V such that me and my friends can all get a pie piece of size V. The answer should be given as a floating point number with an absolute error of at most 10 −3.

    Sample Input

    3
    3 3
    4 3 3
    1 24
    5
    10 5
    1 4 2 3 4 5 6 5 4 2

    Sample Output

    25.1327
    3.1416
    50.2655

    #include <iostream>
    #include <algorithm>
    #include <iomanip>
    #include <stdio.h>
    #define pi 3.14159265359
    const double eps = 1e-7;
    using namespace std;
    int t,n,k,r;
    int a[10000+5];
    int check(double mid)
    {
        int ans = 0;
        for(int i=1; i<=n; i++)    ans += a[i]/mid ;
        if(ans >= k+1) return 1;
        return 0;
    }
    int main()
    {
        int mx;
        cin>>t;
        while(t--)
        {
            mx = 0;
            cin>>n>>k;
            for(int i=1; i<=n; i++)
            {
                cin>>r;
                a[i] = r*r;
                mx = max(mx , a[i]);
            }
            double l = 0 , r = mx , R;
            while(l+eps<=r)
            {
                double mid = (l+r)/2;
                if(check(mid))
                {
                    R = mid ;    l = mid ;
                }
                else
                    r = mid;
            }
            cout<<(fixed)<<setprecision(4)<<R*pi<<endl;
        }
        return 0;
    }
    所遇皆星河
  • 相关阅读:
    subprocess模块讲解
    正则
    logging日志模块
    2-30hashlib模块讲解
    json pickle复习 shelve模块讲解
    XML、PyYAML和configparser模块讲解
    os模块
    2-25sys模块和shutil模块讲解
    随机生成模块
    时间模块
  • 原文地址:https://www.cnblogs.com/Shallow-dream/p/11708599.html
Copyright © 2011-2022 走看看