zoukankan      html  css  js  c++  java
  • 最小生成树专题

     

    B - Networking

     POJ - 1287 

    You are assigned to design network connections between certain points in a wide area. You are given a set of points in the area, and a set of possible routes for the cables that may connect pairs of points. For each possible route between two points, you are given the length of the cable that is needed to connect the points over that route. Note that there may exist many possible routes between two given points. It is assumed that the given possible routes connect (directly or indirectly) each two points in the area. 
    Your task is to design the network for the area, so that there is a connection (direct or indirect) between every two points (i.e., all the points are interconnected, but not necessarily by a direct cable), and that the total length of the used cable is minimal.
    Input
    The input file consists of a number of data sets. Each data set defines one required network. The first line of the set contains two integers: the first defines the number P of the given points, and the second the number R of given routes between the points. The following R lines define the given routes between the points, each giving three integer numbers: the first two numbers identify the points, and the third gives the length of the route. The numbers are separated with white spaces. A data set giving only one number P=0 denotes the end of the input. The data sets are separated with an empty line. 
    The maximal number of points is 50. The maximal length of a given route is 100. The number of possible routes is unlimited. The nodes are identified with integers between 1 and P (inclusive). The routes between two points i and j may be given as i j or as j i. 
    Output
    For each data set, print one number on a separate line that gives the total length of the cable used for the entire designed network.
    Sample Input
    1 0
    
    2 3
    1 2 37
    2 1 17
    1 2 68
    
    3 7
    1 2 19
    2 3 11
    3 1 7
    1 3 5
    2 3 89
    3 1 91
    1 2 32
    
    5 7
    1 2 5
    2 3 7
    2 4 8
    4 5 11
    3 5 10
    1 5 6
    4 2 12
    
    0
    Sample Output
    0
    17
    16
    26
    Title
    #include <iostream>
    #include <cmath>
    #include <algorithm>
    #include <queue>
    #include <string>
    #include <cstring>
    #include <cstdio>
    #include <cstdlib>
    #define ll long long
    using namespace std;
    const int mxn = 10010;
    int n,m,t,k;
    int far[mxn];
    struct node
    {
        int u,v,cost;
        bool operator < (const node & a) const
        {
            return a.cost >cost;
        }
    } rt[mxn];
    int get(int x)
    {
        if(far[x]==x) return x;
        far[x] = get( far[x] );
        return far[x] ;
    }
    int serach(int l,int r)
    {
        if(get(l)==get(r)) return 0;
        far[ get(l) ] = get(r) ;
        return 1 ;
    }
    int main()
    {
        while(cin>>n&&n)
        {
            
            cin>>m;
            for(int i=0; i<=mxn; i++) far[i] =  i ;
            for(int i=1; i<=m; i++)
                cin>> rt[i].u >> rt[i].v >> rt[i].cost ;
            sort(rt+1,rt+1+m);
            int ans = 0 ,cnt = 0;
            for(int i=1; i<=m; i++)
            {
                if(serach(rt[i].u ,rt[i].v))
                {
                    ans += rt[i].cost;
                    cnt++;
                }
                if(cnt==n-1)    break;
            }
            cout<<ans<<endl;
        }
        return 0;
    }
    Code

    K - 还是畅通工程

     HDU - 1233 

    某省调查乡村交通状况,得到的统计表中列出了任意两村庄间的距离。省政府“畅通工程”的目标是使全省任何两个村庄间都可以实现公路交通(但不一定有直接的公路相连,只要能间接通过公路可达即可),并要求铺设的公路总长度为最小。请计算最小的公路总长度。 
    Input
    测试输入包含若干测试用例。每个测试用例的第1行给出村庄数目N ( < 100 );随后的N(N-1)/2行对应村庄间的距离,每行给出一对正整数,分别是两个村庄的编号,以及此两村庄间的距离。为简单起见,村庄从1到N编号。 
    当N为0时,输入结束,该用例不被处理。 
    Output
    对每个测试用例,在1行里输出最小的公路总长度。 
    Sample Input
    3
    1 2 1
    1 3 2
    2 3 4
    4
    1 2 1
    1 3 4
    1 4 1
    2 3 3
    2 4 2
    3 4 5
    0
    Sample Output
    3
    5
    
    
            
      
    Huge input, scanf is recommended.
    Hint
    Hint
            
     
    Title
    #include <iostream>
    #include <cmath>
    #include <algorithm>
    #include <queue>
    #include <string>
    #include <cstring>
    #include <cstdio>
    #include <cstdlib>
    #define ll long long
    using namespace std;
    const int mxn = 10010;
    int n,m,t,k;
    int far[mxn];
    struct node
    {
        int u,v,cost;
        bool operator < (const node & a) const
        {
            return a.cost >cost;
        }
    } rt[mxn];
    int get(int x)
    {
        if(far[x]==x) return x;
        far[x] = get( far[x] );
        return far[x] ;
    }
    int serach(int l,int r)
    {
        if(get(l)==get(r)) return 0;
        far[ get(l) ] = get(r) ;
        return 1 ;
    }
    int main()
    {
        while(cin>>n&&n)
        {
            m = n*(n-1)/2;
            //cin>>m;
            for(int i=0; i<=mxn; i++) far[i] =  i ;
            for(int i=1; i<=m; i++)
                cin>> rt[i].u >> rt[i].v >> rt[i].cost ;
            sort(rt+1,rt+1+m);
            int ans = 0 ,cnt = 0;
            for(int i=1; i<=m; i++)
            {
                if(serach(rt[i].u ,rt[i].v))
                {
                    ans += rt[i].cost;
                    cnt++;
                }
                if(cnt==n-1)    break;
            }
            cout<<ans<<endl;
        }
        return 0;
    }
    Code
    所遇皆星河
  • 相关阅读:
    maven项目的构建命令
    linux的find命令
    python函数中参数前面的*和**的含义
    python中字典和集合的使用
    python中列表和元组的基本操作
    在Python中写中文注释格式
    linux 文件操作基本命令
    linux脚本实现递归阶乘
    base64
    从DispatcherServlet中的doService了解spring组件之间的处理流程
  • 原文地址:https://www.cnblogs.com/Shallow-dream/p/12064107.html
Copyright © 2011-2022 走看看