zoukankan      html  css  js  c++  java
  • BZOJ1083|SCOI2005繁忙的都市|最小生成树

    Description
    城市C是一个非常繁忙的大都市,城市中的道路十分的拥挤,于是市长决定对其中的道路进行改造。城市C的道路是这样分布的:城市中有n个交叉路口,有些交叉路口之间有道路相连,两个交叉路口之间最多有一条道路相连接。这些道路是双向的,且把所有的交叉路口直接或间接的连接起来了。每条道路都有一个分值,分值越小表示这个道路越繁忙,越需要进行改造。但是市政府的资金有限,市长希望进行改造的道路越少越好,于是他提出下面的要求: 1. 改造的那些道路能够把所有的交叉路口直接或间接的连通起来。 2. 在满足要求1的情况下,改造的道路尽量少。 3. 在满足要求1、2的情况下,改造的那些道路中分值最大的道路分值尽量小。任务:作为市规划局的你,应当作出最佳的决策,选择那些道路应当被修建。
    Input
    第一行有两个整数n,m表示城市有n个交叉路口,m条道路。接下来m行是对每条道路的描述,u, v, c表示交叉路口u和v之间有道路相连,分值为c。(1≤n≤300,1≤c≤10000)
    Output
    两个整数s, max,表示你选出了几条道路,分值最大的那条道路的分值是多少。
    Sample Input
    4 5
    1 2 3
    1 4 5
    2 4 7
    2 3 6
    3 4 8
    Sample Output
    3 6

    分析:这一道题就是一个裸的最小生成树……

    #include<iostream>
    #include<cstdio>
    #include<cstdlib>
    #include<algorithm>
    using namespace std;
    
    struct node{
           int from,to,v;
    }e[3001];
    
    int fa[301];
    int tot=0;
    
    int find(int x){ return fa[x]=fa[x]==x?x:find(fa[x]); }
    
    bool cmp(node a,node b) { return a.v<b.v; }
    
    int main()
    {
        int n,m;
        cin >> n >> m;
        cout << n-1 << " ";
        for (int i=1; i<=m; i++) 
        {
            int x,y,z;
            cin >> x >> y >> z;
            e[++tot].to=y; e[tot].from=x; e[tot].v=z; 
            e[++tot].to=x; e[tot].from=y; e[tot].v=z; 
        }
        for (int i=1; i<=n; i++) fa[i]=i;
        sort(e+1,e+tot+1,cmp);
        int ans;
        for (int i=1; i<=tot; i++)
              if (find(e[i].from)!=find(e[i].to))
              {
                 fa[e[i].from]=find(fa[e[i].to]);
                 ans=e[i].v;
              }
        cout << ans;
        system("pause");
        return 0;
    }
  • 相关阅读:
    定时机制
    选择排序
    二分插入排序
    无名管道pipe
    Makefile
    Python下划线与命名规范
    Django IDE 开发环境的搭建
    Apache如何添加虚拟目录
    在Eclipse下如何安装插件
    Python的模块、包等概念的理解
  • 原文地址:https://www.cnblogs.com/Shymuel/p/4656315.html
Copyright © 2011-2022 走看看