zoukankan      html  css  js  c++  java
  • ZOJ

    Edward, the headmaster of the Marjar University, is very busy every day and always forgets the date.

    There was one day Edward suddenly found that if Monday was the 1st, 11th or 21st day of that month, he could remember the date clearly in that week. Therefore, he called such week "The Lucky Week".

    But now Edward only remembers the date of his first Lucky Week because of the age-related memory loss, and he wants to know the date of the N-th Lucky Week. Can you help him?

    Input

    There are multiple test cases. The first line of input is an integer T indicating the number of test cases. For each test case:

    The only line contains four integers Y, M, D and N (1 ≤ N ≤ 109) indicating the date (Y: year, M: month, D: day) of the Monday of the first Lucky Week and the Edward's query N.

    The Monday of the first Lucky Week is between 1st Jan, 1753 and 31st Dec, 9999 (inclusive).

    Output

    For each case, print the date of the Monday of the N-th Lucky Week.

    Sample Input

    2
    2016 4 11 2
    2016 1 11 10
    

    Sample Output

    2016 7 11
    2017 9 11
    

    这个题的关键在于如何去求一个循环周期的时间

    1. //1:四百年一轮回,从闰年和平年的判定可以推出。

    2. //2:由上一条可以用程序判断出每四百年有2058个天为1,11,21的星期一,直接用。

    代码:

    #include<cstdio>
    #include<iostream>
    #include<cstring>
    #include<algorithm>
    #include<queue>
    #include<stack>
    #include<set>
    #include<vector>
    #include<map>
    #include<cmath>
    const int maxn=1e5+5;
    typedef long long ll;
    using namespace std;
    int a[13]= {0,31,28,31,30,31,30,31,31,30,31,30,31};
    int b[13]= {0,31,29,31,30,31,30,31,31,30,31,30,31};
    bool run(int x) {
    	if((x%4==0&&x%100!=0)||x%400==0) {
    		return true;
    	} else {
    		return false;
    	}
    }
    int main() {
    	int T;
    	cin>>T;
    	int year  ,month ,day,N;
    	while(T--) {
    		scanf("%d%d%d%d",&year,&month,&day,&N);
    		year +=(N/2058)*400;
    		N%=2058;
    		int k=day;
    		int cnt=0;
    		int s=1;
    
    		while(s<=N) {
    			if(run(year)) {
    				while(day<=b[month]) {
    
    					if((cnt)%7==0&&(day==1||day==11||day==21)) {
    						if(s==N)
    						{
    							cout<<year<<" "<<month<<" "<<day<<endl;
    						}
    						s++;
    					}
    					cnt++;
    					day++;
    
    				}
    				day=1;
    				month++;
    				if(month>12) {
    					month=1;
    					year++;
    				}
    			}
    
    
    			else {
    				while(day<=a[month]) {
    
    					if((cnt)%7==0&&(day==1||day==11||day==21)) {
    						if(s==N)
    						{
    							cout<<year<<" "<<month<<" "<<day<<endl;
    						}
    						s++;
    					}
    					cnt++;
    					day++;
    				}
    				day=1;
    				month++;
    				if(month>12) {
    					month=1;
    					year++;
    				}
    			}
    		}
    
    
    	}
    	return 0;
    }
    
  • 相关阅读:
    一次向svn中增加所有新增文件 svn add all new files
    cocos2d-x Lua与OC互相调用
    IOS8开发之实现App消息推送
    IOS Remote Notification
    再见
    vue中$router.push打开新窗口
    nuxt拦截IE浏览器
    百度统计api获取数据
    css滚动条样式自定义
    nuxt框架Universal和Spa两种render mode的区别
  • 原文地址:https://www.cnblogs.com/Staceyacm/p/10781749.html
Copyright © 2011-2022 走看看