zoukankan      html  css  js  c++  java
  • Party All the Time(三分)

    In the Dark forest, there is a Fairy kingdom where all the spirits will go together and Celebrate the harvest every year. But there is one thing you may not know that they hate walking so much that they would prefer to stay at home if they need to walk a long way.According to our observation,a spirit weighing W will increase its unhappyness for S 3*W units if it walks a distance of S kilometers. 
    Now give you every spirit's weight and location,find the best place to celebrate the harvest which make the sum of unhappyness of every spirit the least.

    Input

    The first line of the input is the number T(T<=20), which is the number of cases followed. The first line of each case consists of one integer N(1<=N<=50000), indicating the number of spirits. Then comes N lines in the order that x [i]<=x [i+1]for all i(1<=i<N). The i-th line contains two real number : X i,W i, representing the location and the weight of the i-th spirit. ( |x i|<=10 6, 0<w i<15 )

    Output

    For each test case, please output a line which is "Case #X: Y", X means the number of the test case and Y means the minimum sum of unhappyness which is rounded to the nearest integer.

    Sample Input

    1
    4
    0.6 5
    3.9 10
    5.1 7
    8.4 10

    Sample Output

    Case #1: 832

    基本是三分模板题(注意w也是浮点数)

    代码:

    #include<cstdio>
    #include<iostream>
    #include<algorithm>
    #include<cstring>
    #include<map>
    #include<set>
    #include<stack>
    #include<queue>
    #include<vector>
    #include<cmath>
    
    const int maxn=1e5+5;
    typedef long long ll;
    using namespace std;
    struct node
    {
    	double s;
    	double w;
    }p[maxn];
    int n;
    double fun(double x)
    {
    	double sum=0;
    	for(int t=0;t<n;t++)
    	{
    	double ss;
    	ss=fabs(p[t].s-x);
    	sum+=ss*ss*ss*p[t].w;	
    	}
    	return sum;
    }  
    int main()
    {
    	int T;
    	cin>>T;
    	for(int t=0;t<T;t++)
    	{
    		scanf("%d",&n);
    		for(int j=0;j<n;j++)
    		{
    			scanf("%lf%lf",&p[j].s,&p[j].w);
    		}
    		double l=p[0].s,r=p[n-1].s;
    		double m1,m2;
    		while(r-l>1e-6)
    		{
    			
    			m1=(l+r)/2;
    			m2=(m1+r)/2;
    			if(fun(m1)>fun(m2)+1e-6)
    			{
    				l=m1;
    			}
    			else
    			{
    				r=m2;
    			}
    		}
    		int sss=fun(l)+0.5;
    		cout<<"Case #"<<t+1<<": "<<sss<<endl;
    	}
    	
    	return 0;
    }
    
  • 相关阅读:
    Linux cat
    Linux touch
    Win10 UAP 绑定
    Win10 资源文件
    Win10 启动模拟器
    Win10 安装Vs2015 社区版和企业版各个问题汇总
    Win10 开发者模式开启
    android 入门-本地化语言
    android 入门-基础了解
    wp8 入门到精通 定时更新瓷贴
  • 原文地址:https://www.cnblogs.com/Staceyacm/p/10781771.html
Copyright © 2011-2022 走看看