zoukankan      html  css  js  c++  java
  • POJ-1001-Exponentiation(高精度大数)

    Problems involving the computation of exact values of very large magnitude and precision are common. For example, the computation of the national debt is a taxing experience for many computer systems. 

    This problem requires that you write a program to compute the exact value of R nwhere R is a real number ( 0.0 < R < 99.999 ) and n is an integer such that 0 < n <= 25.

    Input

    The input will consist of a set of pairs of values for R and n. The R value will occupy columns 1 through 6, and the n value will be in columns 8 and 9.

    Output

    The output will consist of one line for each line of input giving the exact value of R^n. Leading zeros should be suppressed in the output. Insignificant trailing zeros must not be printed. Don't print the decimal point if the result is an integer.

    Sample Input

    95.123 12
    0.4321 20
    5.1234 15
    6.7592  9
    98.999 10
    1.0100 12
    

    Sample Output

    548815620517731830194541.899025343415715973535967221869852721
    .00000005148554641076956121994511276767154838481760200726351203835429763013462401
    43992025569.928573701266488041146654993318703707511666295476720493953024
    29448126.764121021618164430206909037173276672
    90429072743629540498.107596019456651774561044010001
    1.126825030131969720661201
    代码:
    import java.math.BigDecimal;
    import java.util.Scanner;
    
    
    public class Main {
        public static void main(String[] args) {
        Scanner s = new Scanner(System.in);
        while(s.hasNext()){
            BigDecimal b = s.nextBigDecimal();
            BigDecimal ans = BigDecimal.valueOf(1);
            int n = s.nextInt();
            while(n-- > 0)
                ans = ans.multiply(b);
            String string = ans.stripTrailingZeros().toPlainString().toString();
            if(string.startsWith("0."))
                string = string.substring(1);
            System.out.println(string);
        }
            s.close();
        }
    }
    知识点总结
    1、stripTrailingZeros() ,返回类型为BigDecimal的小于此数的但除去尾部的0的数值。
    2、toPlainString(),返回BigDecimal类型的String类型字符串。
    3、startsWith(),确定此实例的开头是否与指定的字符串匹配。
    4、substring(),返回一个新的字符串,它是此字符串的一个子字符串。该子字符串始于指定索引处的字符,一直到此字符串末尾。
  • 相关阅读:
    java中CyclicBarrier的使用
    java并发中CountDownLatch的使用
    java中Locks的使用
    java 中的fork join框架
    java中ThreadPool的介绍和使用
    java中的daemon thread
    java中interrupt,interrupted和isInterrupted的区别
    java中的Atomic类
    怎么在java中关闭一个thread
    java中join的使用
  • 原文地址:https://www.cnblogs.com/Staceyacm/p/11326270.html
Copyright © 2011-2022 走看看