zoukankan      html  css  js  c++  java
  • Monkey and Banana

    Description

    A group of researchers are designing an experiment to test the IQ of a monkey. They will hang a banana at the roof of a building, and at the mean time, provide the monkey with some blocks. If the monkey is clever enough, it shall be able to reach the banana by placing one block on the top another to build a tower and climb up to get its favorite food.

    The researchers have n types of blocks, and an unlimited supply of blocks of each type. Each type-i block was a rectangular solid with linear dimensions (xi, yi, zi). A block could be reoriented so that any two of its three dimensions determined the dimensions of the base and the other dimension was the height.

    They want to make sure that the tallest tower possible by stacking blocks can reach the roof. The problem is that, in building a tower, one block could only be placed on top of another block as long as the two base dimensions of the upper block were both strictly smaller than the corresponding base dimensions of the lower block because there has to be some space for the monkey to step on. This meant, for example, that blocks oriented to have equal-sized bases couldn't be stacked.

    Your job is to write a program that determines the height of the tallest tower the monkey can build with a given set of blocks.

    Input Specification

    The input file will contain one or more test cases. The first line of each test case contains an integer n, representing the number of different blocks in the following data set. The maximum value for n is 30. Each of the next n lines contains three integers representing the values xi, yi and zi. Input is terminated by a value of zero (0) for n.

    Output Specification

    For each test case, print one line containing the case number (they are numbered sequentially starting from 1) and the height of the tallest possible tower in the format "Case case: maximum height = height"

    Sample Input

    1
    10 20 30
    2
    6 8 10
    5 5 5
    7
    1 1 1
    2 2 2
    3 3 3
    4 4 4
    5 5 5
    6 6 6
    7 7 7
    5
    31 41 59
    26 53 58
    97 93 23
    84 62 64
    33 83 27
    0
    

    Sample Output

    Case 1: maximum height = 40
    Case 2: maximum height = 21
    Case 3: maximum height = 28
    Case 4: maximum height = 342


    //代码如下:
    #include <iostream>
    #include <cstring>
    #include <algorithm>
    using namespace std;
    structbox
    {
        int length;
        int width;
        int h;
    };
    int max(int a, int b)
    {
        if( a > b )
           return a;
        return b;
    }
    int min(int a,int b)
    {
        if( a < b )
           return a;
        return b;
    }
    box  boxes[31*3];
    //用来保存下面一块方块到上面一块方块的高度之和
    int temp[31*3]; //将方块按照长以及宽,高从小到大排序!!是从小到大!!!
    bool gcd(boxb1, boxb2) { if(b1.length != b2.length) return b1.length < b2.length; else if(b1.width != b2.width) return b1.width < b2.width; else return b1.h < b2.h; } int dp(int n) { sort(boxes,boxes+3*n,gcd); temp[0] = boxes[0].h; int maxH = temp[0]; //核心内容,将第i块作为第j块的底,计算出最大的h.并且保存。
    for(int i = 1; i < 3*n;i++) { temp[i] = 0; for(int j = i - 1 ; j >= 0; j--) { if(boxes[j].length < boxes[i].length && boxes[j].width < boxes[i].width && temp[i] < temp[j]) { temp[i] = temp[j]; } } temp[i] += boxes[i].h; if(maxH < temp[i]) maxH = temp[i]; } return maxH; } int main() { int Icase = 0; int n; while(cin>>n && n) { for(int i = 0 ; i < 3*n;i++) { boxes[i].h = 0; } memset(temp,0,sizeof(temp)); Icase++; int a,b,c; int total = 0; for(int i = 0 ; i < n;i++) { cin>>a>>b>>c; boxes[total].length = max(a,b); boxes[total].width = min(a,b); boxes[total++].h = c; boxes[total].length = max(a,c); boxes[total].width = min(a,c); boxes[total++].h = b; boxes[total].length = max(c,b); boxes[total].width = min(c,b); boxes[total++].h = a; } cout<<"Case "<<Icase<<": maximum height = "<<dp(n)<<endl; } return 0; }


  • 相关阅读:
    Informix日期获取上周上月昨天去年SQL
    Oracle-创建一个DBLink的方法
    Kafka-Partitions与Replication Factor 调整准则
    Linux-删除文件空间不释放问题解决
    Redhat7-Oracle-sqlldr-安装配置
    Centos7-安装oracle客户端11.2.0.4
    Centos7-单机安装jumpserver
    Redhat6.4-yum本地源安装配置
    Linux-zip unzip 命令日常使用
    xxl-job日志
  • 原文地址:https://www.cnblogs.com/T8023Y/p/3225448.html
Copyright © 2011-2022 走看看