zoukankan      html  css  js  c++  java
  • UVA 562 Dividing coins

     

      Dividing coins 

    It's commonly known that the Dutch have invented copper-wire. Two Dutch men were fighting over a nickel, which was made of copper. They were both so eager to get it and the fighting was so fierce, they stretched the coin to great length and thus created copper-wire.

    Not commonly known is that the fighting started, after the two Dutch tried to divide a bag with coins between the two of them. The contents of the bag appeared not to be equally divisible. The Dutch of the past couldn't stand the fact that a division should favour one of them and they always wanted a fair share to the very last cent. Nowadays fighting over a single cent will not be seen anymore, but being capable of making an equal division as fair as possible is something that will remain important forever...


    That's what this whole problem is about. Not everyone is capable of seeing instantly what's the most fair division of a bag of coins between two persons. Your help is asked to solve this problem.


    Given a bag with a maximum of 100 coins, determine the most fair division between two persons. This means that the difference between the amount each person obtains should be minimised. The value of a coin varies from 1 cent to 500 cents. It's not allowed to split a single coin.

    Input 

    A line with the number of problems n, followed by n times:
    • a line with a non negative integer m ($m le 100$) indicating the number of coins in the bag
    • a line with m numbers separated by one space, each number indicates the value of a coin.

    Output 

    The output consists of n lines. Each line contains the minimal positive difference between the amount the two persons obtain when they divide the coins from the corresponding bag.

    Sample Input 

    2
    3
    2 3 5
    4
    1 2 4 6

    Sample Output 

    0
    1

    //0-1背包的变形,以总的钱数的一半为目标进行背包,即将其中的一组最接近总的钱数一半。将该题的总的钱数的一半类比为0-1背包的总的体积。将各个钱值类比为0-1背包中的w[i],v[i]即可。

    #include <iostream>
    #include <algorithm>
    #include <cstring>
    using namespace std;
    int coin[105];
    int SumOfCoin[500*100/2 + 5];
    int W[105];
    int backpack(int n,int sum,int halfOfSum)
    {
        int sum1 = 0;
        for(int i = 1; i <= n;i++)
        {
            for(int j = halfOfSum; j >= 0; j--)
            {
                if(j >= W[i])
                  SumOfCoin[j] = max(SumOfCoin[j],SumOfCoin[j-W[i]] + coin[i]);
            }
        }
        for(int i = 0 ; i <= halfOfSum; i++)
           sum1 = max(sum1,SumOfCoin[i]);
        return sum - 2*sum1;//返回分完后两组的差值。
    }
    int main()
    {
        int t;
        cin>>t;
        while(t)
        {
            memset(coin,0,sizeof(coin));
            memset(SumOfCoin,0,sizeof(SumOfCoin));
            memset(W,0,sizeof(W));
            int n;
            cin>>n;
            int sum = 0;
            for(int i = 1 ; i <= n;i++)
            {
                cin>>coin[i];
                W[i] = coin[i];
                sum += coin[i];
            }
            cout<<backpack(n,sum,sum/2)<<endl;
            t--;
        }
        return 0;
    }
     
  • 相关阅读:
    Android开发之旅1:环境搭建及HelloWorld
    程序员学习视频教程汇总
    Maven项目下update maven后Eclipse报错:java.lang.ClassNotFoundException: ContextLoaderL
    查看控制层从前端传来的参数
    PostMethod和GetMethod用法
    @Transient的用法和格式化页面展示的数据格式
    修改hosts
    javascript:history.go(-1)的使用
    JsonConfig的jsonConfig.setExcludes的用法
    验证登录超时,在登录后跳转超时时的页面
  • 原文地址:https://www.cnblogs.com/T8023Y/p/3237776.html
Copyright © 2011-2022 走看看