zoukankan      html  css  js  c++  java
  • Big Event in HDU

    Description

    Nowadays, we all know that Computer College is the biggest department in HDU. But, maybe you don't know that Computer College had ever been split into Computer College and Software College in 2002.
    The splitting is absolutely a big event in HDU! At the same time, it is a trouble thing too. All facilities must go halves. First, all facilities are assessed, and two facilities are thought to be same if they have the same value. It is assumed that there is N (0<N<1000) kinds of facilities (different value, different kinds).
     

    Input

    Input contains multiple test cases. Each test case starts with a number N (0 < N <= 50 -- the total number of different facilities). The next N lines contain an integer V (0<V<=50 --value of facility) and an integer M (0<M<=100 --corresponding number of the facilities) each. You can assume that all V are different.
    A test case starting with a negative integer terminates input and this test case is not to be processed.
     

    Output

    For each case, print one line containing two integers A and B which denote the value of Computer College and Software College will get respectively. A and B should be as equal as possible. At the same time, you should guarantee that A is not less than B.
     

    Sample Input

    2 10 1 20 1 3 10 1 20 2 30 1 -1
     

    Sample Output

    20 10 40 40
     
    //与divided coins类似。只不过是将同一件物品的数量当成多件物品。
     
    #include <iostream>
    #include <cstring>
    #include <algorithm>
    using namespace std;
    int sumOfValue[50*100*50];
    int V[50*100+5];
    int W[50*100+5];
    int Divide(int total,int half)
    {
        for(int i = 1; i <= total; i++)
        {
            for(int j = half; j >= 0; j--)
            {
                if(j >= W[i])
                  sumOfValue[j] = max(sumOfValue[j],sumOfValue[j - W[i]] + V[i]);
            }
        }
        int sum1 = 0;
         for(int i = 0 ; i <= half; i++)
           sum1 = max(sum1,sumOfValue[i]);
     return sum1;
    }
    int main()
    {
        int n;
        while(cin>>n && n > 0)
        {
            memset(W,0,sizeof(W));//不初始化会WA
            memset(V,0,sizeof(V));
            memset(sumOfValue,0,sizeof(sumOfValue));
            int total = 1;
            int count,x;
            int sum= 0;
            for(int i = 1 ; i <= n ;i++)
            {
                cin>>x>>count;
                sum += x*count;
                for(int j = 0 ; j < count;j++)
                {
                   V[total] = x;
                   W[total] = x;
                   total++;
                }
            }
          cout<<sum-Divide(total,sum/2)<<" "<<Divide(total,sum/2)<<endl;
        }
        return 0;
    }
  • 相关阅读:
    IE6下,设置了domain,导致target指向iframe时,无法打开链接的问题及解决
    contains和compareDocumentPosition 方法来确定是否HTML节点间的关系
    xCode4.2中导入OpenFlow库到项目中出现编译警告warning: Semantic Issue: Writable atomic property
    NSXMLParser具体解析xml的应用详解
    CoCoa编程中视图控制器与视图类(一)
    CoCoa编程中视图控制器与视图类(二)
    关于值传递(高手请无视)
    程序员人生之DAN疼篇
    jquery杂谈jquery选择符
    怎么样把 swf格式 转换为flv格式
  • 原文地址:https://www.cnblogs.com/T8023Y/p/3237961.html
Copyright © 2011-2022 走看看