zoukankan      html  css  js  c++  java
  • [解题报告]113 Power of Cryptography

     Power of Cryptography 

    Background

    Current work in cryptography involves (among other things) large prime numbers and computing powers of numbers modulo functions of these primes. Work in this area has resulted in the practical use of results from number theory and other branches of mathematics once considered to be of only theoretical interest.

    This problem involves the efficient computation of integer roots of numbers.

    The Problem

    Given an integer tex2html_wrap_inline32 and an integer tex2html_wrap_inline34 you are to write a program that determines tex2html_wrap_inline36 , the positivetex2html_wrap_inline38 root of p. In this problem, given such integers n and pp will always be of the form tex2html_wrap_inline48 for an integerk (this integer is what your program must find).

    The Input

    The input consists of a sequence of integer pairs n and p with each integer on a line by itself. For all such pairs tex2html_wrap_inline56 , tex2html_wrap_inline58 and there exists an integer ktex2html_wrap_inline62 such that tex2html_wrap_inline64 .

    The Output

    For each integer pair n and p the value tex2html_wrap_inline36 should be printed, i.e., the number k such that tex2html_wrap_inline64 .

    Sample Input

    2
    16
    3
    27
    7
    4357186184021382204544

    Sample Output

    4
    3
    1234



    水的一塌糊涂,不解释了
    #include<stdio.h>
    #include<math.h> int main() { double n,p; while(scanf("%lf%lf",&n,&p)!=EOF) printf("%.0lf\n",pow(p,1.0/n)); return 0; }

     HDU AC

    #include <stdio.h>
    #include <math.h>
    int main()
    {
        double n;
        double p;
        while(scanf("%lf%lf",&n,&p)!=EOF)
        {
            int begin=1;
            int end=1000000000;
            int mid;
            while (begin <= end)
            {
                mid=(begin+end)/2;
                double temp=pow(mid,n);
                if (temp==p) 
                    {
                    printf("%d\n",mid);
                    break;
                } 
                else if(temp>p) 
                    {
                    end=mid-1;
                } 
                else
                {
                    begin = mid + 1;
                }
            }
        }
        return 0;
    }
  • 相关阅读:
    Map 中的EntrySet() ,Map的遍历
    Struts2拦截器原理
    基于 <tx> 和 <aop> 命名空间的声明式事务管理
    Spring AOP Example 文件下载:
    Struts2拦截器
    好多开发文档——官网打不开的福音
    threejs样例
    bootCDN,用了都说好
    react拷贝index.html很恶心之解决办法
    网络爬虫好
  • 原文地址:https://www.cnblogs.com/TheLaughingMan/p/2919100.html
Copyright © 2011-2022 走看看