zoukankan      html  css  js  c++  java
  • [解题报告]382 Perfection

     Perfection 

    From the article Number Theory in the 1994 Microsoft Encarta: ``If abc are integers such that a = bc, a is called a multiple of b or of c, and b or c is called a divisor or factor of a. If c is not tex2html_wrap_inline41 , b is called a proper divisor of a. Even integers, which include 0, are multiples of 2, for example, -4, 0, 2, 10; an odd integer is an integer that is not even, for example, -5, 1, 3, 9. A perfect number is a positive integer that is equal to the sum of all its positive, proper divisors; for example, 6, which equals 1 + 2 + 3, and 28, which equals 1 + 2 + 4 + 7 + 14, are perfect numbers. A positive number that is not perfect is imperfect and is deficient or abundant according to whether the sum of its positive, proper divisors is smaller or larger than the number itself. Thus, 9, with proper divisors 1, 3, is deficient; 12, with proper divisors 1, 2, 3, 4, 6, is abundant."

    Problem Statement

    Given a number, determine if it is perfect, abundant, or deficient.

    Input

    A list of N positive integers (none greater than 60,000), with 1 < N < 100. A 0 will mark the end of the list.

    Output

    The first line of output should read PERFECTION OUTPUT. The next N lines of output should list for each input integer whether it is perfect, deficient, or abundant, as shown in the example below. Format counts: the echoed integers should be right justified within the first 5 spaces of the output line, followed by two blank spaces, followed by the description of the integer. The final line of output should read END OF OUTPUT.

    Sample Input

    15 28 6 56 60000 22 496 0

    Sample Output

    PERFECTION OUTPUT
       15  DEFICIENT
       28  PERFECT
        6  PERFECT
       56  ABUNDANT
    60000  ABUNDANT
       22  DEFICIENT
      496  PERFECT
    END OF OUTPUT


    注意输入输出方式

    #include<stdio.h>
    #include<string.h>
    void panduan(long i)
    {
        long j;
        long sum=0;
        for(j=1;j<i;j++)
        {
            if(i%j==0) sum+=j;
        }
        if(i>sum) printf("%5d  DEFICIENT\n",i);
        if(i==sum) printf("%5d  PERFECT\n",i);
        if(i<sum) printf("%5d  ABUNDANT\n",i);
    
    }
    int main()
    {
        long i,j=0;
        printf("PERFECTION OUTPUT\n");
        while(scanf("%ld",&i)!=EOF&&i)
        panduan(i);
        printf("END OF OUTPUT\n");
        return 0;
    }
  • 相关阅读:
    Windows配置深度学习环境详细教程(二):conda工具的使用
    Windows配置深度学习环境详细教程(一):安装Pycharm和Miniconda
    性能基准DevOps之如何提升脚本执行效率
    【Go语言绘图】图片添加文字(二)
    Cesium中用到的图形技术——Computing the horizon occlusion point
    Cesium中用到的图形技术——Horizon Culling
    Unity3D学习笔记3——Unity Shader的初步使用
    C++:异常处理
    mysql数据库备份
    编程小工具
  • 原文地址:https://www.cnblogs.com/TheLaughingMan/p/2923058.html
Copyright © 2011-2022 走看看