zoukankan      html  css  js  c++  java
  • [解题报告]541 Error Correction

      Error Correction 

    A boolean matrix has the parity property when each row and each column has an even sum, i.e. contains an even number of bits which are set. Here's a 4 x 4 matrix which has the parity property:

    1 0 1 0
    0 0 0 0
    1 1 1 1
    0 1 0 1
    

    The sums of the rows are 2, 0, 4 and 2. The sums of the columns are 2, 2, 2 and 2.


    Your job is to write a program that reads in a matrix and checks if it has the parity property. If not, your program should check if the parity property can be established by changing only one bit. If this is not possible either, the matrix should be classified as corrupt.

    Input 

    The input file will contain one or more test cases. The first line of each test case contains one integer n(n<100), representing the size of the matrix. On the next n lines, there will be n integers per line. No other integers than 0 and 1 will occur in the matrix. Input will be terminated by a value of 0 for n.

    Output 

    For each matrix in the input file, print one line. If the matrix already has the parity property, print ``OK". If the parity property can be established by changing one bit, print ``Change bit (i,j)" where i is the row and j the column of the bit to be changed. Otherwise, print ``Corrupt".

    Sample Input 

    4
    1 0 1 0
    0 0 0 0
    1 1 1 1
    0 1 0 1
    4
    1 0 1 0
    0 0 1 0
    1 1 1 1
    0 1 0 1
    4
    1 0 1 0
    0 1 1 0
    1 1 1 1
    0 1 0 1
    0
    

    Sample Output 

    OK
    Change bit (2,3)
    Corrupt
    

    Miguel A. Revilla 
    1999-01-11
     
     
    没啥好讲的。。。。
    #include<stdio.h>
    int ar[101][101];
    int main()
    {
        int n,i,j;
        while (scanf("%d",&n)!=EOF&&n) 
        {
            for(i=0;i<n;i++)
                for (j=0;j<n;j++)
                    scanf("%d",&ar[i][j]);
            int cnt_r=0,cnt_c=0;
            int x=-1,y=-1;
            for (i=0;i<n;i++) 
            {
                int sum=0;
                for(j=0;j<n;j++) sum+=ar[i][j];
                if(sum&1) cnt_r++,x=i;
            }
            for (j=0;j<n;j++) 
            {
                int sum=0;
                for (i=0;i<n;i++) sum+=ar[i][j];
                if (sum&1) cnt_c++,y=j;
            }
            if(x==-1&&y==-1) puts("OK");
            else if(cnt_r==1&&cnt_c==1) printf("Change bit (%d,%d)\n",x+1,y+1);
            else puts("Corrupt");
        }
        return 0;
    }
  • 相关阅读:
    Word Ladder
    Android下使用dlopen函数动态调用.so链接库
    Android系统中调试动态链接库so文件的步骤
    eclipse下如何将android项目生成apk
    ACE_Task::putq
    static_cast 与reinterpret_cast
    Linux创建与解压zip, tar, tar.gz,tar.bz2文件
    SVN Externals Definitions[类似于软链接的功能]
    有效运用auto_ptr
    字符串匹配算法 之 基于DFA(确定性有限自动机)的字符串模式匹配算法
  • 原文地址:https://www.cnblogs.com/TheLaughingMan/p/2924708.html
Copyright © 2011-2022 走看看