zoukankan      html  css  js  c++  java
  • [解题报告]543 Goldbach's Conjecture

      Goldbach's Conjecture 

    In 1742, Christian Goldbach, a German amateur mathematician, sent a letter to Leonhard Euler in which he made the following conjecture:

    Every number greater than 2 can be written as the sum of three prime numbers.

    Goldbach cwas considering 1 as a primer number, a convention that is no longer followed. Later on, Euler re-expressed the conjecture as:

    Every even number greater than or equal to 4 can be expressed as the sum of two prime numbers.


    For example:

    • 8 = 3 + 5. Both 3 and 5 are odd prime numbers.
    • 20 = 3 + 17 = 7 + 13.
    • 42 = 5 + 37 = 11 + 31 = 13 + 29 = 19 + 23.

    Today it is still unproven whether the conjecture is right. (Oh wait, I have the proof of course, but it is too long to write it on the margin of this page.)


    Anyway, your task is now to verify Goldbach's conjecture as expressed by Euler for all even numbers less than a million.

    Input 

    The input file will contain one or more test cases.

    Each test case consists of one even integer n with $6 \le n < 1000000$.

    Input will be terminated by a value of 0 for n.

    Output 

    For each test case, print one line of the form n = a + b, where a and b are odd primes. Numbers and operators should be separated by exactly one blank like in the sample output below. If there is more than one pair of odd primes adding up to n, choose the pair where the difference b - a is maximized.

    If there is no such pair, print a line saying ``Goldbach's conjecture is wrong."

    Sample Input 

    8
    20
    42
    0
    

    Sample Output 

    8 = 3 + 5
    20 = 3 + 17
    42 = 5 + 37
    

    Miguel A. Revilla 
    1999-01-11
     
     
    哥德巴赫猜想,建质数表,前面有类似的题,速秒
    #include <stdio.h>
    #include <string.h>
    int used[1000005];
    int prim[1000005];
    int main()
    {
        int n,count=0;
        int i,j;
        memset(used,0,sizeof(used));
        for (i=2;i<=1000000;i++)
            if (!used[i])
            {
                prim[count++] = i;
                for(j=2*i;j<=1000000;j+=i)
                    used[j]=1;
            }
        while(scanf("%d",&n)&&n)
        {
            int flag=0;
            for(i=1;prim[i]<=n/2;i++)
                if (!used[n-prim[i]])
                {
                    printf("%d = %d + %d\n",n,prim[i],n-prim[i]);
                    flag=1; break;
                }
            if (!flag) printf("Goldbach's conjecture is wrong.\n");
        }
        return 0;
    }
  • 相关阅读:
    IP地址分类
    Python 加密 shellcode 免杀
    java翻译到mono C#实现系列(2) mono实现GridView 横向滚动
    Hello Jexus(转并修改)
    @using (Html.BeginForm())和@{Html.BeginForm();}@{Html.EndForm();}对比
    FindLine把多行查找改为多行替换
    java翻译到mono C#实现系列(1) 重写返回键按下的事件
    mono 的System.Data.SqlClient小记录
    架构文件夹说明
    Xamarin Mono For Android 4.6.07004看不到新建android
  • 原文地址:https://www.cnblogs.com/TheLaughingMan/p/2924716.html
Copyright © 2011-2022 走看看