zoukankan      html  css  js  c++  java
  • [解题报告]10041 Vito's Family

      Problem C: Vito's family 

    Background 

    The world-known gangster Vito Deadstone is moving to New York. He has a very big family there, all of them living in Lamafia Avenue. Since he will visit all his relatives very often, he is trying to find a house close to them.

    Problem 

    Vito wants to minimize the total distance to all of them and has blackmailed you to write a program that solves his problem.

    Input 

    The input consists of several test cases. The first line contains the number of test cases.

    For each test case you will be given the integer number of relatives r ( 0 < r < 500) and the street numbers (also integers) $s_1, s_2, \ldots, s_i, \ldots, s_r$ where they live ( 0 < si < 30000 ). Note that several relatives could live in the same street number.

    Output 

    For each test case your program must write the minimal sum of distances from the optimal Vito's house to each one of his relatives. The distance between two street numbers si and sj is dij= |si-sj|.

    Sample Input 

    2
    2 2 4 
    3 2 4 6
    

    Sample Output 

    2
    4
    

    Miguel Revilla 
    2000-11-19
     
     
     
    冒泡排序,求中位数,再求解
     
     
    #include<stdio.h>
    int main()
    {
        int k,n,i,j;
        int temp,s,sum,b;
        int a[30000];
        scanf("%d",&k);
        while(k--)
        {   sum=0;
            scanf("%d",&n);
            for(i=0;i<n;i++)
            scanf("%d",&a[i]);
            for(i=0;i<n-1;i++)
                for(j=0;j<n-i-1;j++)
                if(a[j]<a[j+1])
                {
                    temp=a[j+1];
                    a[j+1]=a[j];
                    a[j]=temp;
                }
    
            if(n%2==0)
            s=(a[n/2-1]+a[n/2])/2;
            else
            s=a[n/2];
            for(i=0;i<n;i++)
            {
             b=s-a[i];
             if(b<0)
             b=b*-1;
             sum+=b;
            }
            printf("%d\n",sum);
        }
        return 0;
    }
  • 相关阅读:
    TO DO List
    springboot 热部署
    <dependencyManagement>的作用
    人体工程学座椅
    temp
    temp
    声明式编程和命令式编程的本质区别
    weak first question
    Spring依赖注入方式和依赖来源
    SpringBoot 整合 H2 数据库
  • 原文地址:https://www.cnblogs.com/TheLaughingMan/p/2926980.html
Copyright © 2011-2022 走看看