zoukankan      html  css  js  c++  java
  • [解题报告]10019 Funny Encryption Method

    Funny Encryption Method

    The Problem

    History : 
    A student from ITESM Campus Monterrey plays with a new encryption method for numbers. These method consist of the following steps:

    Steps :  Example 
    1) Read the number N to encrypt M = 265 
    2) Interpret N as a decimal number X1= 265 (decimal) 
    3) Convert the decimal interpretation of N to its binary representation X1= 100001001 (binary) 
    4) Let b1 be equal to the number of 1’s in this binary representation B1= 3 
    5) Interpret N as a Hexadecimal number X2 = 265 (hexadecimal) 
    6) Convert the hexadecimal interpretation of N to its binary representation X2 = 1001100101 
    7) Let b2 be equal to the number of 1’s in the last binary representation B2 = 5 
    8) The encryption is the result of  M xor (b1*b2) M xor (3*5) = 262

    This student failed Computational Organization, that’s why this student asked the judges of ITESM Campus Monterrey internal ACM programming Contest to ask for the numbers of 1’s bits of this two representations so that he can continue playing.

    Task : 
    You have to write a program that read a Number and give as output the number b1 and b2

    The Input

    The first line will contain a number N which is the number of cases that you have to process. Each of the following N Lines ( 0<N<=1000) will contain the number M (0<M<=9999, in decimal representation)  which is the number the student wants to encrypt.

    The Output

    You will have to output N lines, each containing the number b1 and b2 in that order, separated by one space  corresponding to that lines number to crypt

    Sample Input

    3
    265
    111
    1234

    Sample Output

    3 5 
    6 3 
    5 5

    C语言的数制转换还真是不方便啊。。。

    #include<stdio.h>
    int main()
    {
        int cas;
        int i,j,n,n1;
        scanf("%d",&cas);
        while (cas--)
        {
            scanf("%d",&n);
            int b1=0;
            for(i=n;i;i/=2) b1+=i%2;
            int n1=0;
            for (i=n,j=0;i;i/=10,j++) n1+=(i%10)*(int)pow(16,(double)j);
            int b2=0;
            for (i=n1;i;i/=2) b2+=i%2;
            printf("%d %d\n",b1,b2);
        }
        return 0;
    }
  • 相关阅读:
    【POJ 1655】Balancing Act
    【POJ 2631】 Roads in the North
    【洛谷 1002】 过河卒
    【洛谷 3178】树上操作
    【洛谷 1060】开心的金明
    【洛谷 2709】小B的询问
    【洛谷 1972】HH的项链
    JavaSpark-sparkSQL
    java8下spark-streaming结合kafka编程(spark 2.3 kafka 0.10)
    Kafka 使用Java实现数据的生产和消费demo
  • 原文地址:https://www.cnblogs.com/TheLaughingMan/p/2927388.html
Copyright © 2011-2022 走看看